Can't set as Home Page the Other Bookmarks folder

VERIFIED FIXED in Firefox 67

Status

()

defect
P5
normal
VERIFIED FIXED
4 months ago
4 months ago

People

(Reporter: cfogel, Assigned: standard8)

Tracking

({regression})

Trunk
Firefox 67
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox65 wontfix, firefox66 wontfix, firefox67 verified)

Details

Attachments

(2 attachments)

Affected versions

  • 67.0a1(Build ID_20190310214003), 66.0b15, 65.0.2;

Affected platforms

  • Windows 10, macOS 10.12.6, Ubuntu 16.04

Steps to reproduce

  1. Launch Firefox and access about:preferences#home
  2. Click on the dropdown for Homepage and new windows;
  3. Choose the Custom Urls... option;
  4. Click on the Use Bookmark... button;
  5. Click on the Other Bookmarks option;
  6. Click on the Ok button.

Expected result

  • the bookmarks + folder links are added in the Custom URLs input field

Actual result

  • onClick effect is triggered for the button, but nothing happens;

Regression range

  • aTrif helped with getting the regression range:
  • Last good build_date: 2018-05-25 11:35:52.672000 changeset: 8d9da33b8e4ffc559774c7c9c144cba819d6b886
  • First bad build_date: 2018-05-25 11:49:21.138000 changeset: 8a4d896b435b50718c66a691c9fdec6bf7bfba2d
  • Pushlog URL: link
  • issue not reproduce on 60.0b3;

Additional notes

  • attached recording with the issue;
  • as per bug 1451756 there are some inconsistencies in this area;
  • for this issue; it's that while the OK does nothing for the Other bookmarks folder, for the Bookmarks Toolbar and the Bookmarks Menu options it does "something".
Has Regression Range: --- → yes
Has STR: --- → yes

Mark, looks like your patches caused a regression here. Can you investigate?

Flags: needinfo?(standard8)
Priority: -- → P5

(Maybe this is intentional?)

Something that I spotted is that the virtual guids used for Other/Mobile virtual queries are invalid - I filed bug 1534322 for that. It does aid to breaking this, but not completely. For example, selecting either one of Other or Mobile those throws an error at the moment, but the toolbar & menu ones don't.

The actual issue here is that we're not getting the concrete Guid for the node, so we're using the virtual query guid to try and build what's in the folder. That's simple to fix.

I'm not quite sure why people would want to select a whole folder, but stopping that would probably currently be more complicated than fixing this.

Assignee: nobody → standard8
Status: NEW → ASSIGNED
Flags: needinfo?(standard8)
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 67

I have managed to reproduce this issue using Firefox 67.0a1 (20190311215435) on Windows 10 x64.
This issue is verified fixed using Firefox 67.0a1 (20190315093917) on Windows 10 x64, Ubuntu 18.04 x64, macOS 10.14.3.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.