Update pdf.js to version 2.2.67

RESOLVED FIXED in Firefox 67

Status

()

enhancement
RESOLVED FIXED
2 months ago
2 months ago

People

(Reporter: RyanVM, Assigned: RyanVM)

Tracking

Trunk
Firefox 67
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox67 fixed)

Details

Assignee

Description

2 months ago

+++ This bug was initially created as a clone of Bug #1532355 +++

Changes since last update:
#10608 Reduce usage of Date.now() in src/core/worker.js
#10610 Add type validation to the default_preferences generation (PR 10548 follow-up)
#10605 Convert let to const if possible in, and improve unit test coverage for, src/display/display_utils.js
#10615 Handle corrupt ASCII85Decode inline images with whitespace "inside" of the EOD marker (issue 10614)
#10621 Don't scale SVG stroke width by text matrix
#10634 Move NativeImageDecoder into a separate file, and convert it to a class
#10633 Convert MurmurHash3_64 to an ES6 class

Comment 1

2 months ago
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/a298dcb1bc36
Update pdf.js to version 2.2.67. r=bdahl

Comment 2

2 months ago
bugherder
Status: NEW → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 67
Assignee

Updated

2 months ago
Blocks: 1535726
Assignee

Updated

2 months ago
Blocks: 1538064
Assignee

Updated

2 months ago
No longer blocks: 1538064
You need to log in before you can comment on or make changes to this bug.