Closed Bug 1534289 Opened 6 months ago Closed 4 months ago

Downloads Panel summary is hardly readable in dark mode

Categories

(Firefox :: Theme, defect, P3)

defect
Points:
1

Tracking

()

VERIFIED FIXED
Firefox 68
Iteration:
68.4 - Apr 29 - May 12
Tracking Status
firefox65 --- wontfix
firefox66 --- wontfix
firefox67 --- wontfix
firefox68 --- verified

People

(Reporter: csasca, Assigned: dao)

References

Details

Attachments

(2 files)

Affected versions

  • Firefox 65.0.2
  • Firefox Beta 66.0b14
  • Firefox Nightly 67.0a1

Affected platforms

  • Windows 10 (x64)
  • Ubuntu 18.04 (x64)
  • macOS 10.12

Prerequisites

  • Have the dark theme active.

Steps to reproduce

  1. Start Firefox
  2. Add the attribute showingsummary="true" to #downloadsFooter in browser toolbox
  3. Click on the Downloads Button

Expected result

  • The message "0 files downloading" is readable

Actual result

  • The message "0 files downloading" is barely readable (see attachment)

Regression range

  • This is not a regression since it is reproducing on the earliest builds where the #downloadFooter string was available and the "0 files downloading" could be triggered by the show summary string.

Additional notes

  • On Ubuntu 18.04 the message is not as hard to read as in Windows and macOS systems.
Duplicate of this bug: 1550705
Assignee: nobody → dao+bmo
Status: NEW → ASSIGNED
Priority: -- → P3
Summary: Downloads Panel message is hardly readable → Downloads Panel message is hardly readable in dark mode
Summary: Downloads Panel message is hardly readable in dark mode → Downloads Panel summary is hardly readable in dark mode
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3fd55231ce62
Fix download panel summary color in dark mode. r=ntim
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68
Flags: qe-verify+

I have reproduced this issue using Firefox 67.0a1 (2019.03.11) on Win 10 x64.
I can confirm this issue is fixed, I verified using Firefox 68.0b8 on Win 10 x64, macOS 10.13.6 and Ubuntu 18.04 x64.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
Iteration: --- → 68.4 - Apr 29 - May 12
Points: --- → 1
You need to log in before you can comment on or make changes to this bug.