Edited usernames not synced on Nightly

VERIFIED FIXED in Firefox 67

Status

()

defect
VERIFIED FIXED
3 months ago
3 months ago

People

(Reporter: mirabela.lobontiu, Assigned: eoger)

Tracking

({regression})

Firefox 67
Firefox 68
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox65 unaffected, firefox66 unaffected, firefox67 verified, firefox68 verified)

Details

Attachments

(4 attachments)

Reporter

Description

3 months ago
Posted image not-synced.png

Devices:

  • HTC 10 (Android 8.0);
  • Samsung Galaxy Note8 (Android 8.0);
  • Huawei P9 Lite (Android 6.0);
  • Sony Xperia z5 Premium (Android 7.1.1).

Build:

  • Nightly 67.0a1 (2019-03-11);

Steps to reproduce:

  1. Log in with the same account on desktop (Windows 10), and Android.
  2. Create some "Saved logins" (i.e. https://news.ycombinator.com/login, https://www.facebook.com, https://twitter.com, https://en.m.wikipedia.org).
  3. Sync all devices.
  4. Edit a username for one of the saved logins, then sync.

Expected result:
The login username displayed on Desktop is edited like on Android.

Actual result:
The username is not changed.

Notes:
Not reproducible on Samsung Galaxy S8 (Android 8.0), OnePlus 5T (Android 9.0), iPhone SE (12.1.4).
In the attached screenshot, the first image is from desktop, the second is from Android.
On Release and Beta 66.0b13, the behavior is filed in issue https://bugzilla.mozilla.org/show_bug.cgi?id=1532098.

Reporter

Updated

3 months ago
See Also: → 1532098

eoger: fallout/follow-up from Bug 1532098. Can you investigate?

Flags: needinfo?(eoger)
Assignee

Updated

3 months ago
Flags: needinfo?(eoger)
Assignee

Comment 5

3 months ago

I posted a patch that does two things:

  • Disallow the host to be edited: allowing it triggers a ton of bugs because hostname is different from formSubmitURL. Probably for the same reasons on Desktop users can't change the hostname for a login item. Let's do the reasonable thing and follow suit.
  • Forces a sync of the item by touching timePasswordChanged (Desktop does that too).
Assignee

Updated

3 months ago
Assignee: nobody → eoger
Status: NEW → ASSIGNED

Comment 6

3 months ago
Pushed by eoger@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8536a746d9cc
p1 - Make login item host read-only. r=nalexander
https://hg.mozilla.org/integration/autoland/rev/15dd5838706f
p2 - Touch timePasswordChanged on password modification. r=nalexander
https://hg.mozilla.org/integration/autoland/rev/981af21f38b1
p3 - Use correct search criteria to find original login. r=nalexander

Comment 7

3 months ago
bugherder
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68

Should we uplift to 67 to avoid shipping with this regression?

Flags: needinfo?(eoger)
Assignee

Comment 9

3 months ago

Yes I believe we should as the patch introducing the regression is in 67

Flags: needinfo?(eoger)
Assignee

Comment 10

3 months ago

Comment on attachment 9050473 [details]
Bug 1534290 p1 - Make login item host read-only.

Beta/Release Uplift Approval Request

  • Feature/Bug causing the regression: Bug 1532098
  • User impact if declined: Edited logins usernames on Android will not be synced
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: 1. Connect Android and Desktop a Sync account.
  1. Create login on Desktop, sync all devices.
  2. Change username of the login, sync all devices.
  3. Desktop should show the change.
    [Do the same test with the password instead]
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Not too risky as it's contained in a content page.
  • String changes made/needed:
  • Do you want to request approval of these patches as well?: on, on
Attachment #9050473 - Flags: approval-mozilla-beta?
Assignee

Updated

3 months ago
Flags: qe-verify?
Flags: qe-verify? → qe-verify+
QA Whiteboard: [qa-triaged]
Keywords: regression
Reporter

Comment 11

3 months ago

Verified as fixed on the latest Nightly 68.0a1 (2019-03-20) on:

  • HTC 10 (Android 8.0);
  • Samsung Galaxy Note8 (Android 8.0);
  • Huawei P9 Lite (Android 6.0);
  • Sony Xperia z5 Premium (Android 7.1.1).
QA Whiteboard: [qa-triaged]
Flags: qe-verify+

Comment on attachment 9050473 [details]
Bug 1534290 p1 - Make login item host read-only.

Contained fix for a Syncing regression on Android, uplift approved for pour next 67 beta given our work on exposing Firefox accounts and syncing in our primary UI in the 67/68 timeframe. Thanks!

Attachment #9050473 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Comment 14

3 months ago

Hi, I can confirm that this issue is fixed on the latest version of Beta 67.0b4 using Samsung Galaxy Tab S3 (Android 8.0) and Samsung Galaxy Note 8 (Android 9).

Status: RESOLVED → VERIFIED

I confirm also the fix on the latest Beta build (67.0b4) using the following devices:

  • HTC 10 (Android 8.0);
  • Huawei P9 Lite (Android 6.0);
  • Sony Xperia z5 Premium (Android 7.1.1).
You need to log in before you can comment on or make changes to this bug.