Closed Bug 1534297 Opened 2 years ago Closed 2 years ago

Adjust context menu location on lists without images

Categories

(Firefox :: New Tab Page, defect, P1)

defect

Tracking

()

RESOLVED WONTFIX
Iteration:
67.4 - Mar 11 - 17
Tracking Status
firefox-esr60 --- unaffected
firefox65 --- unaffected
firefox66 --- unaffected
firefox67 --- affected

People

(Reporter: cmuresan, Assigned: wolasi)

References

Details

Attachments

(1 file)

[Affected versions]:

  • Firefox Nightly 67.0a1, Build ID 20190310214003

[Affected Platforms]:

  • All Windows
  • All Mac
  • All Linux

[Prerequisites]:

[Steps to reproduce]:

  1. Start the browser and open a new tab.
  2. Scroll down to the "List (without borders, without images, 6 items)" section.
  3. Hover one of the items and observe the context menu position.

[Expected results]:

  • The context menu is anchored to the item.

[Actual results]:

  • The context menu is not anchored to any part of the item.

[Notes]:

  • The issue is worse on Mac, as there the context menu can appear over parts of the text.
  • Attached a screen recording of the issue.
Assignee: nobody → wkonu
Iteration: --- → 67.4 - Mar 11 - 17
Priority: -- → P1

This as intended for the current version of lists without images. We'll be evaluating the various content modules when the layout experiments conclude. And at this time we will take another pass at context actions.

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.