Proper fix for race condition in devtools/client/aboutdebugging-new/test/browser/browser_aboutdebugging_telemetry_runtime_updates.js

RESOLVED FIXED in Firefox 67

Status

enhancement
RESOLVED FIXED
3 months ago
2 months ago

People

(Reporter: jorendorff, Assigned: jorendorff)

Tracking

unspecified
Firefox 67

Firefox Tracking Flags

(firefox67 fixed)

Details

Attachments

(1 attachment)

Assignee

Description

3 months ago

Spun off from bug 1533574, in which I landed a workaround that doesn't really fix the bug. jdescottes pointed out the real issue on review:

I think the issue is that since I landed the original fix we now change the runtime name displayed after connection / disconnection.

So the removeUSB helper should check both that runtime.name and runtime.shortname are not found in the sidebar. Feel free to land this but we should file a follow up to implement the correct fix

Assignee

Updated

3 months ago
Assignee: nobody → jorendorff
See Also: → 1534499

Comment 2

2 months ago
bugherder
Status: NEW → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 67
You need to log in before you can comment on or make changes to this bug.