Link to image/tiff file loads in wrong window (with plug-in installed)

VERIFIED DUPLICATE of bug 153454

Status

()

P3
normal
VERIFIED DUPLICATE of bug 153454
17 years ago
16 years ago

People

(Reporter: jason1, Assigned: serhunt)

Tracking

Trunk
Future
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
[build 2002062109]
If you have a TIFF plug-in installed (such as QuickTime), and click on a link to
a TIFF file, and you have more than one browser window open, the plug-in may be
loaded into the wrong window.

In particular, if you start with one browser window, and click on a link that
should open in a new browser window (e.g. a link that has TARGET=_blank), a new
window will be opened but the plug-in will be loaded into the original window
instead of the new one.

And if you start with two or more browser windows open, and click on a link that
should load into the same browser window, the plug-in *may* be loaded into one
of the other browser windows. This does not occur for all windows -- I suspect
that at any given time there is one "special" window into which the TIFF plug-in
will always load no matter what window the link was in.

This problem does not occur if you type the TIFF URL into the location bar, or
if the document's MIME type is anything other than exactly "image/tiff".

Note that if you don't have a TIFF plug-in installed, a somewhat different
problem occurs (bug 153451).
(Reporter)

Comment 1

17 years ago
*** Bug 113859 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 2

17 years ago
Also note that if the plug-in does happen to get loaded into the correct window
(because there were no other windows open, or the link was in the "special"
window), it will not be able to display the image because of bug 153454.

Comment 3

17 years ago
that is just too weird, I can confirm this using the build from 20020621 on win98

setting to future until we flush out what will be done the next go round
Assignee: beppe → av
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P3
Target Milestone: --- → Future

Comment 4

17 years ago
marking as dup of bug 153454, that bug has a patch attached that will fix this
issue as well, they are all related to the same issue

*** This bug has been marked as a duplicate of 153454 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 5

16 years ago
mass duplicate verifications . For filtering purposes, pls use keywd
"massdupverification"

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.