Closed Bug 1534652 Opened 4 years ago Closed 4 years ago

Google search engine gets removed after deleting the foo.js default preferences file

Categories

(Firefox :: Search, defect)

defect
Not set
normal

Tracking

()

VERIFIED FIXED
Firefox 68
Tracking Status
firefox66 --- wontfix
firefox67 --- wontfix
firefox68 --- verified

People

(Reporter: atrif, Assigned: mkaply)

Details

Attachments

(3 files)

Attached image nogoog2.gif

Affected versions

  • Firefox 66.0 (20190311211048)
  • Firefox 67.0a1 (20190312095443)

Affected platforms

  • macOS 10.13.6
  • Windows 10 x64
  • Ubuntu 18.04 x64

Prerequisites

  • Place the attached foo.js file inside the firefox/defaults/pref folder .

Steps to reproduce

  1. Open Firefox with a clean profile.
  2. Perform a random search in URL bar.
  3. Close Firefox.
  4. Go to “firefox/defaults/pref” and delete “foo.js”.
  5. Open Firefox with same profile used at step 1.
  6. Inspect search engines.

Expected result

  • Google search engine is available.

Actual result

  • Google search engine is no longer displayed/available.

Regression range

  • I will get back with a regression range ASAP.

Additional Notes

  • On 66.0 the issue is intermittent.
  • Attached a screen recording with the issue.
Attached file foo.js
Has Regression Range: --- → no
Has STR: --- → yes
Pushed by mozilla@kaply.com:
https://hg.mozilla.org/integration/autoland/rev/46fbb035f335
Add try catch whenever querying mozparams. r=adw
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68
Assignee: nobody → mozilla

Mike, is that something that would be safe and valuable to uplift or can we let it ride the 68 train? Thanks

Flags: needinfo?(mozilla)

The shield study that was going to use this is using a different mechanism, so this can ride the trains.

The scenario that happened was test only.

Flags: needinfo?(mozilla)

Since the code no longer exists on latest versions, I've tested this using Nightly 68.0a1 (20190410100020) and it no longer reproduces. We can safely close this issue.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.