Closed Bug 1534699 Opened 5 months ago Closed 5 months ago

Synced Tabs panel is blank in subsequent windows

Categories

(Firefox :: Sync, defect)

Desktop
All
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 68
Tracking Status
firefox-esr60 --- unaffected
firefox66 --- wontfix
firefox67 + verified
firefox68 --- verified

People

(Reporter: Gabi, Assigned: markh)

References

Details

(Keywords: regression)

Attachments

(2 files)

Attached image syncedtabs.png

[Affected versions]:

  • 67.0a1
  • 66.0b14

[Affected platforms]:

  • Windows 10 x64
  • MacOS 10.12.16
  • Ubuntu 16.4

[Steps to reproduce]:

  1. Launch Firefox
  2. Navigate to Customize
  3. Drag Forget button to the toolbar
  4. Click Forget button
  5. Click on Forget! button
  6. Go to Synced Tabs from View History, bookmarks and more menu
  7. Observe the Synced Tabs panel

[Expected result]:

  • Sing in to Sync should be displayed under the Synced Tabs panel

[Actual result]:

  • Synced Tabs panel is blank after using Forget about some browsing history

[Regression range]:

  • Will return with the regression range asap
Has Regression Range: --- → no
Has STR: --- → yes
Has Regression Range: no → yes

Paolo, possibly Bug 1482645?

Blocks: 1482645
Flags: needinfo?(paolo.mozmail)

Who should take this now that Paolo has left?

Flags: needinfo?(paolo.mozmail) → needinfo?(jaws)

(In reply to Patricia Lawless from comment #3)

Who should take this now that Paolo has left?

Looks like Mark reviewed the patch, and this is sync-related, so let's move there and ask the Sync team to take a look.

Component: Toolbars and Customization → Sync
Flags: needinfo?(jaws) → needinfo?(markh)

It's actually worse than as described:

  • Open Firefox, open "sync tabs", note the "setup sync" state.
  • Open another top-level window, open "sync tabs" - it is blank.

Patch forthcoming.

Assignee: nobody → markh
Flags: needinfo?(markh)
Summary: Synced Tabs panel is blank after using Forget about some browsing history → Synced Tabs panel is blank in subsequent windows

[Tracking Requested - why for this release]:
Given comment #5, I think this is more serious than we initially thought, and wants uplifting. The patch as it is right now looks small enough.

Pushed by mhammond@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a5dfa26d0646
ensure new windows default to 'setup sync' state. r=eoger
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68

Comment on attachment 9053192 [details]
Bug 1534699 - ensure new windows default to 'setup sync' state. r?eoger

Beta/Release Uplift Approval Request

  • Feature/Bug causing the regression: Bug 1482645
  • User impact if declined: "Synced Tabs" panel may be blank
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Very small patch, impact limited to sync ui
  • String changes made/needed: None
Attachment #9053192 - Flags: approval-mozilla-beta?

The patch is small and seems well understood but since this is landed on Nightly and we have clear STRs from QA in comment #0, I would like our QA team to verify the fix on Nightly before and after uplifting to beta.

Also, given that we regressed that since 63, would it be possible to have an automatic test to prevent regressing it again in the future? Thanks

Flags: qe-verify+
Flags: needinfo?(markh)
QA Whiteboard: [qa-triaged]

Hi, I managed to reproduce this issue in older versions of Firefox like Beta and Release but this issue no longer occurs in the Latest Nightly build 68.0a1 (2019-03-27), I verified this issue on Windows 10, Ubuntu and Mac OsX.

Comment on attachment 9053192 [details]
Bug 1534699 - ensure new windows default to 'setup sync' state. r?eoger

Low risk patch for a regression, verified by our QA on Nightly, uplift approved for 67 beta 6, thanks.

Attachment #9053192 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Hi, This issue is Verified as fixed in the latest Firefox Beta 67.0b6 on Windows 10, Ubuntu and Mac OsX, I will mark this issue accordingly.

Status: RESOLVED → VERIFIED
QA Whiteboard: [qa-triaged]
Flags: qe-verify+

Sadly a test for this is tricky.

Flags: needinfo?(markh)
You need to log in before you can comment on or make changes to this bug.