Vertical Scrollbar doesn't appear Until the Cookie Confirmation Dialog is Dismissed

RESOLVED WORKSFORME

Status

()

Core
Networking: Cookies
--
trivial
RESOLVED WORKSFORME
16 years ago
14 years ago

People

(Reporter: Phil Miller, Assigned: Stephen P. Morse)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
BuildID:    2002-06-20-08

When loading a page requiring a vertical scroll bar which wants to set a cookie,
the vertical scroll bar doesn't appear until after the user has dismissed the
dialog by pressing "Yes" or "No". It should be drawn immediately, so that the
screen does not have to redraw twice (once when the page mostly loads, again
when the scroll bar is displayed).

Reproducible: Always
Steps to Reproduce:
Here's an example that's easy:
1. Turn on cookie confirmation
2. Visit glish.com, which request setting a cookie when it loads
3. Select "no"
4. On the right-hand side, click the A+ or A- links to reload the page with a
larger or smaller font size.
5. Note that when the cookie dialog is visible, the vertical scrollbar is not,
and that it is drawn in later, forcing at least a partial redraw/reflow of the page.

Comment 1

16 years ago
cookies/layout
Assignee: Matti → morse
Component: Browser-General → Cookies
QA Contact: imajes-qa → tever
(Reporter)

Comment 2

16 years ago
Apparently, things have changed since I reported this, way back when, so that
nothing seems to be rendered until cookies are dealt with. I may complain about
that elsewhere, but the problem here is gone.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 3

14 years ago
REOPEN:
this is WFM if there is no clear fix.
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Comment 4

14 years ago
Resolving WFM based on comment 2.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.