When document.body.bgColor changed twice in a row, not reflected on screen immediately

VERIFIED DUPLICATE of bug 1886

Status

()

defect
P3
normal
VERIFIED DUPLICATE of bug 1886
20 years ago
2 months ago

People

(Reporter: giorgio, Assigned: vidur)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [TESTCASE], )

Attachments

(2 attachments)

Reporter

Description

20 years ago
Changing background doesn't automatically refresh the window.
You have to modify something else in the page to have the window refreshed

Updated

20 years ago
Summary: browser window refreshing → When document.body.bgColor changed twice in a row, not reflected on screen immediately

Comment 3

20 years ago
It seems this only occurs when you update the bgColor (of the document.body)
element, twice in a row. The second update isn't painted to the screen
imediately but some outside action (or other DOM update) is needed to refresh
it.

Then when there is additional stuff on the screen the color updates are done in
patches.

Updated

20 years ago
Whiteboard: [TESTCASE]

Comment 4

20 years ago
As Daryl pointed out, bug 1886 seems to be related to this one.

Updated

20 years ago
Status: NEW → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → DUPLICATE

Comment 5

20 years ago
This is definitely a DUP of 1886

*** This bug has been marked as a duplicate of 1886 ***

Updated

20 years ago
Status: RESOLVED → VERIFIED

Comment 6

20 years ago
[bugday] verified as duplicate bug.
Component: DOM → DOM: Core & HTML
Product: Core → Core
You need to log in before you can comment on or make changes to this bug.