Closed Bug 1534845 Opened 2 years ago Closed 2 years ago

[Context Menu] Telemetry on click of link menus for pocket new tab

Categories

(Firefox :: New Tab Page, enhancement)

enhancement
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1531585

People

(Reporter: pdahiya, Unassigned)

References

Details

Scope of this bug is to review and implement telemetry for pocket new tab on click of link menus. Context Menu in pocket new tab reuses LinkMenu component that dispatches siteInfo and impression details in default activity stream

https://searchfox.org/mozilla-central/source/browser/components/newtab/content-src/components/LinkMenu/LinkMenu.jsx#30

SiteInfo for pocket stories is defined in Card.jsx -
https://searchfox.org/mozilla-central/source/browser/components/newtab/content-src/components/Card/Card.jsx#260

Impression for a link menu option is defined in https://searchfox.org/mozilla-central/source/browser/components/newtab/content-src/lib/link-menu-options.js#72

and logged if shouldSendImpressionStats for a feature is true.

For pocket top stories in default activity stream, we are capturing impressions
https://searchfox.org/mozilla-central/source/browser/components/newtab/lib/SectionsManager.jsm#49

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1531585
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.