Closed Bug 1534867 Opened 2 years ago Closed 2 years ago

TVg1 and TVg3 fail on win32 only

Categories

(Core :: CSS Parsing and Computation, defect, P3)

x86
Windows
defect

Tracking

()

RESOLVED INVALID
Tracking Status
firefox67 --- affected

People

(Reporter: mats, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: regression)

Simply touching some of the <summary> tests makes
TVg1 and TVg3 fail on win32 only (not win64, nor any other platform):
https://treeherder.mozilla.org/#/jobs?repo=try&revision=dc8a5ea160ca68d321cd27cb33356ef59d13487b&group_state=expanded&selectedJob=233540764
That is, make some change to them in one patch, then revert that
change in the next so that the file is exactly as the original.
I assume the test framework checks the date of the file or which
files are included in the patches or something to decide whether
to run these tests.

I assumed that it was my changes in bug 205202 / bug 288704 that
made them fail but it turns out it's an existing bug. Sigh.

The failures are:
TVg1: Per-test run of ...\overflow-hidden-details.html: : FAILURE
TVg3: Per-test run of ...\overflow-auto-details.html: : FAILURE

There seems to be no details in the log files as to what fails
exactly. I think it's a content process crash, but there's no
crash stack so I don't really know where the bug is.

Joel, do you know how can we figure out what's going on in there?

Flags: needinfo?(jmaher)

TV* jobs run against test files that have been modified; this is an attempt to find intermittent failures introduced by recent test changes. Note that TV* runs as tier 2 -- you shouldn't ever be backed out for failures in TV. More info at https://developer.mozilla.org/en-US/docs/Mozilla/QA/Test_Verification.

The failures are:
TVg1: Per-test run of ...\overflow-hidden-details.html: : FAILURE
TVg3: Per-test run of ...\overflow-auto-details.html: : FAILURE

What is happening here is that TV thinks these are tests, but they are not. TV thinks they are tests because they appear in reftest manifests; they are not test files though, but reference files. Run 'mach reftest layout/reftests/details-summary/overflow-hidden-details.html' and you'll see that no tests are run. TV is doing the same thing and getting the same result. In automation, 0 passes translates into a failure. This is basically a dup of bug 1406407, which I hope to make progress on this year.

In summary, sorry for the confusion, and there's probably nothing for you to worry about here.

Flags: needinfo?(jmaher)

Alright, thanks Geoff!

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → INVALID
See Also: → 1406407
You need to log in before you can comment on or make changes to this bug.