Widget unresponsive to taps until resize

VERIFIED FIXED in Firefox 67

Status

()

defect
VERIFIED FIXED
2 months ago
a month ago

People

(Reporter: kbrosnan, Assigned: petru)

Tracking

(Blocks 1 bug)

Trunk
Firefox 67
All
Android
Points:
---

Firefox Tracking Flags

(firefox67 verified)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 months ago

STR

  • Add widget to homescreen
  • Tap on it
  • Resize widget
  • Tap on it

Expected:

  • tab should open

Actual:

  • tab does not open

https://www.youtube.com/watch?v=iHIaNZ-PaT8

(Reporter)

Comment 1

2 months ago

Using a Pixel 3 running Android 9. Nothing interesting in logcat when I looked at it.

Comment 2

2 months ago

I can't reproduce this, can you supply us with more details please?
Is this device specific?
Did this happened without you actually opening the app? Just installed and manually added the widget?
Any prior settings? Perhaps something in developer options?

Flags: needinfo?(kbrosnan)
(Reporter)

Comment 3

2 months ago

I can reproduce this with a Pixel 2 emulator running Android 9 x86.

Flags: needinfo?(kbrosnan)
(Assignee)

Comment 4

2 months ago

This was a leftover from an initial implementation which needed to track
certain events related to the user adding the search widget.
Otherwise it is not needed as we don't actually expose any widget settings to
be configured by the user before adding it.
Turns out this Activity would actually mess with our PendingIntents which would
not fire for when tapping search widget's elements.

(Assignee)

Updated

2 months ago
Assignee: nobody → petru.lingurar
Status: NEW → ASSIGNED
Keywords: checkin-needed

Comment 5

2 months ago

Pushed by apavel@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/182f8f4a800c
Remove SearchWidgetConfigurationActivity from search's appwidget-provider; r=VladBaicu

Keywords: checkin-needed

Comment 6

2 months ago
bugherder
Status: ASSIGNED → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 67
(Assignee)

Updated

2 months ago
Flags: qe-verify+

Verified as fixed in the latest Nightly build 67.0a1 with Google Pixel 2(Android P) and Google Pixel 3XL (Android P).

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.