Closed Bug 1534939 Opened 7 months ago Closed 5 months ago

Quantumbar: the first item in the URL dropdown list should be LTR when typing a URL

Categories

(Firefox :: Address Bar, defect, P2)

defect
Points:
2

Tracking

()

VERIFIED FIXED
Firefox 68
Iteration:
68.4 - Apr 29 - May 12
Tracking Status
firefox68 --- verified

People

(Reporter: dao, Assigned: adw)

References

Details

(Keywords: rtl)

Attachments

(2 files, 1 obsolete file)

+++ This bug was initially created as a clone of Bug #1290490 +++

User Agent: Mozilla/5.0 (Windows NT 10.0; rv:47.0) Gecko/20100101 Firefox/47.0
Build ID: 20160623154057

Steps to reproduce:

  1. Install Hebrew version of Firefox Developer Edition 49.0a2 (or possibly any RTL version of Firefox having the new design of the URL bar)
  2. a. In the URL bar, type "www.google.com"
    b. In the URL bar, type "google." (with a dot after 'google')
  3. Observe the first item in the dropdown list, the one having "Visit" after the URL and the second with "Search with Google"

Actual results:

Firefox autocompletes A to "/http://www.google.com", and autocompletes B to ".google" (both being RTL'd)
Notice the '/' and the dot's locations.

Expected results:

A and B should have been "http://www.google.com/" and "google.", respectively.
In short, they should be LTR.

Currently it works okay in 47.0.1 (partially, as the "Search with Google" string is incorrectly LTR'd, which is fixed in the new design of the URL bar).

bug 1267355 is somehow related.

Summary: Firefox shouldn't RTL the first item in the URL dropdown list when typing a URL → Quantumbar: the first item in the URL dropdown list should be LTR when typing a URL

Is this still an issue with the quantumbar?

Flags: needinfo?(itiel_yn8)
Attached image Screenshot

(In reply to Dão Gottwald [::dao] from comment #1)

Is this still an issue with the quantumbar?

Yes.

Flags: needinfo?(itiel_yn8)

I think the only thing to fix here is to LTR the text only when the suggestion is counted as a URL (when you have the "Visit" text afterwards, and not "Search with X"), because otherwise I can't see how to URL bar would differentiate between "google." as normal text vs. "google." as a start of a URL.

Is this actually a QB regression, or is just something we'd like to be fixed in the QB?

It's a regression, originally fixed in bug 1290490.

Points: --- → 2
Assignee: nobody → adw
Status: NEW → ASSIGNED
Iteration: --- → 68.4 - Apr 29 - May 12

Option 1: Set a "visit" attribute on the row

Option 2: Set a "lookslikeurl" attribute on the title

Attachment #9063122 - Attachment is obsolete: true
Pushed by dwillcoxon@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/28fa627eb8e9
Quantumbar: Force the first result's title to be LTR when typing a URL. r=dao
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68

LGTM. Thanks!

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.