Closed Bug 1534991 Opened 10 months ago Closed 10 months ago

Perma bc failure browser/base/content/test/static/browser_parsable_css.js | missing chrome://global/skin/media/pictureinpicture.svg referenced from chrome://global/skin/media/videocontrols.css - when Gecko 67 merges to beta on 2019-03-11

Categories

(Firefox :: General, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 67
Tracking Status
firefox-esr60 --- unaffected
firefox65 --- unaffected
firefox66 --- unaffected
firefox67 + verified

People

(Reporter: opoprus, Assigned: mconley)

References

Details

Attachments

(1 file)

[Tracking Requested - why for this release]:

Central as Beta simulation

Treeherder link:https://treeherder.mozilla.org/#/jobs?repo=try&resultStatus=testfailed%2Cbusted%2Cexception%2Cretry%2Cusercancel%2Crunnable&revision=27be6a82207787d8ed2303b0e606f9e3138120fe&selectedJob=233617935

Failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=233617935&repo=try&lineNumber=1755

[task 2019-03-13T12:53:42.233Z] 12:53:42 INFO - TEST-START | browser/base/content/test/static/browser_parsable_css.js

[task 2019-03-13T12:53:44.037Z] 12:53:44 INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/static/browser_parsable_css.js | missing chrome://global/skin/media/pictureinpicture.svg referenced from chrome://global/skin/media/videocontrols.css -
[task 2019-03-13T12:53:44.037Z] 12:53:44 INFO - Stack trace:
[task 2019-03-13T12:53:44.039Z] 12:53:44 INFO - chrome://mochikit/content/browser-test.js:test_ok:1304
[task 2019-03-13T12:53:44.040Z] 12:53:44 INFO - chrome://mochitests/content/browser/browser/base/content/test/static/browser_parsable_css.js:checkAllTheCSS:422
[task 2019-03-13T12:53:44.041Z] 12:53:44 INFO - GECKO(1476) | [Parent 1476, Main Thread] WARNING: Error loading theme icon 'go-down' for stock: Icon 'go-down' not present in theme ubuntu-mono-dark: 'glib warning', file /builds/worker/workspace/build/src/toolkit/xre/nsSigHandlers.cpp, line 135
[task 2019-03-13T12:53:44.042Z] 12:53:44 INFO - GECKO(1476) | (firefox:1476): Gtk-WARNING **: Error loading theme icon 'go-down' for stock: Icon 'go-down' not present in theme ubuntu-mono-dark
[task 2019-03-13T12:53:44.043Z] 12:53:44 INFO - GECKO(1476) | [Parent 1476, Main Thread] WARNING: Error loading theme icon 'document-save' for stock: Icon 'document-save' not present in theme ubuntu-mono-dark: 'glib warning', file /builds/worker/workspace/build/src/toolkit/xre/nsSigHandlers.cpp, line 135
[task 2019-03-13T12:53:44.044Z] 12:53:44 INFO - GECKO(1476) | (firefox:1476): Gtk-WARNING **: Error loading theme icon 'document-save' for stock: Icon 'document-save' not present in theme ubuntu-mono-dark
[task 2019-03-13T12:53:44.045Z] 12:53:44 INFO - GECKO(1476) | [Parent 1476, Main Thread] WARNING: Error loading theme icon 'go-previous' for stock: : 'glib warning', file /builds/worker/workspace/build/src/toolkit/xre/nsSigHandlers.cpp, line 135
[task 2019-03-13T12:53:44.045Z] 12:53:44 INFO - GECKO(1476) | (firefox:1476): Gtk-WARNING **: Error loading theme icon 'go-previous' for stock:
[task 2019-03-13T12:53:44.046Z] 12:53:44 INFO - GECKO(1476) | [Parent 1476, Main Thread] WARNING: Error loading theme icon 'go-previous' for stock: : 'glib warning', file /builds/worker/workspace/build/src/toolkit/xre/nsSigHandlers.cpp, line 135
[task 2019-03-13T12:53:44.047Z] 12:53:44 INFO - GECKO(1476) | (firefox:1476): Gtk-WARNING **: Error loading theme icon 'go-previous' for stock:
[task 2019-03-13T12:53:44.048Z] 12:53:44 INFO - GECKO(1476) | [Parent 1476, Main Thread] WARNING: Error loading theme icon 'go-previous' for stock: : 'glib warning', file /builds/worker/workspace/build/src/toolkit/xre/nsSigHandlers.cpp, line 135
[task 2019-03-13T12:53:44.050Z] 12:53:44 INFO - GECKO(1476) | (firefox:1476): Gtk-WARNING **: Error loading theme icon 'go-previous' for stock:
[task 2019-03-13T12:53:44.050Z] 12:53:44 INFO - GECKO(1476) | [Parent 1476, Main Thread] WARNING: Error loading theme icon 'go-previous' for stock: : 'glib warning', file /builds/worker/workspace/build/src/toolkit/xre/nsSigHandlers.cpp, line 135
[task 2019-03-13T12:53:44.051Z] 12:53:44 INFO - GECKO(1476) | (firefox:1476): Gtk-WARNING **: Error loading theme icon 'go-previous' for stock:
[task 2019-03-13T12:53:44.052Z] 12:53:44 INFO - GECKO(1476) | [Parent 1476, Main Thread] WARNING: Error loading theme icon 'go-next' for stock: : 'glib warning', file /builds/worker/workspace/build/src/toolkit/xre/nsSigHandlers.cpp, line 135
[task 2019-03-13T12:53:44.053Z] 12:53:44 INFO - GECKO(1476) | (firefox:1476): Gtk-WARNING **: Error loading theme icon 'go-next' for stock:
[task 2019-03-13T12:53:44.054Z] 12:53:44 INFO - GECKO(1476) | [Parent 1476, Main Thread] WARNING: Error loading theme icon 'go-next' for stock: : 'glib warning', file /builds/worker/workspace/build/src/toolkit/xre/nsSigHandlers.cpp, line 135
[task 2019-03-13T12:53:44.055Z] 12:53:44 INFO - GECKO(1476) | (firefox:1476): Gtk-WARNING **: Error loading theme icon 'go-next' for stock:
[task 2019-03-13T12:53:44.059Z] 12:53:44 INFO - GECKO(1476) | [Parent 1476, Main Thread] WARNING: Error loading theme icon 'go-next' for stock: : 'glib warning', file /builds/worker/workspace/build/src/toolkit/xre/nsSigHandlers.cpp, line 135
[task 2019-03-13T12:53:44.061Z] 12:53:44 INFO - GECKO(1476) | (firefox:1476): Gtk-WARNING **: Error loading theme icon 'go-next' for stock:
[task 2019-03-13T12:53:44.064Z] 12:53:44 INFO - GECKO(1476) | [Parent 1476, Main Thread] WARNING: Error loading theme icon 'go-next' for stock: : 'glib warning', file /builds/worker/workspace/build/src/toolkit/xre/nsSigHandlers.cpp, line 135
[task 2019-03-13T12:53:44.065Z] 12:53:44 INFO - GECKO(1476) | (firefox:1476): Gtk-WARNING **: Error loading theme icon 'go-next' for stock:
[task 2019-03-13T12:53:44.069Z] 12:53:44 INFO - GECKO(1476) | [Parent 1476, Main Thread] WARNING: Error loading theme icon 'view-refresh' for stock: Icon 'view-refresh' not present in theme ubuntu-mono-dark: 'glib warning', file /builds/worker/workspace/build/src/toolkit/xre/nsSigHandlers.cpp, line 135
[task 2019-03-13T12:53:44.070Z] 12:53:44 INFO - GECKO(1476) | (firefox:1476): Gtk-WARNING **: Error loading theme icon 'view-refresh' for stock: Icon 'view-refresh' not present in theme ubuntu-mono-dark
[task 2019-03-13T12:53:44.076Z] 12:53:44 INFO - GECKO(1476) | [Parent 1476, Main Thread] WARNING: Error loading theme icon 'edit-clear' for stock: : 'glib warning', file /builds/worker/workspace/build/src/toolkit/xre/nsSigHandlers.cpp, line 135
[task 2019-03-13T12:53:44.077Z] 12:53:44 INFO - GECKO(1476) | (firefox:1476): Gtk-WARNING **: Error loading theme icon 'edit-clear' for stock:
[task 2019-03-13T12:53:44.078Z] 12:53:44 INFO - GECKO(1476) | [Parent 1476, Main Thread] WARNING: Error loading theme icon 'window-close' for stock: Icon 'window-close' not present in theme ubuntu-mono-dark: 'glib warning', file /builds/worker/workspace/build/src/toolkit/xre/nsSigHandlers.cpp, line 135
[task 2019-03-13T12:53:44.078Z] 12:53:44 INFO - GECKO(1476) | (firefox:1476): Gtk-WARNING **: Error loading theme icon 'window-close' for stock: Icon 'window-close' not present in theme ubuntu-mono-dark
[task 2019-03-13T12:53:44.079Z] 12:53:44 INFO - Ignored error "Unknown pseudo-class or pseudo-element ‘-moz-has-dir-attr’. Ruleset ignored due to bad selector." on resource://gre-resources/html.css because of whitelist item {"sourceName":"/\b(contenteditable|EditorOverride|svg|forms|html|mathml|ua|pluginproblem)\.css$/i","errorMessage":"/Unknown pseudo-class.*-moz-/i","isFromDevTools":false,"used":true}

This could be caused by Bug 1531101

Flags: needinfo?(mconley)
Assignee: nobody → mconley
Flags: needinfo?(mconley)
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/459a1e1c7b14
Make the pictureinpicture.svg reference Nightly-only for now in videocontrols.css. r=jaws
Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 67
You need to log in before you can comment on or make changes to this bug.