Open Bug 1535127 Opened 9 months ago Updated 27 days ago

Crash in [@ mozilla::recordreplay::FreeRegionSet::ExtractLockHeld]

Categories

(Core :: Web Replay, defect, P5, critical)

Unspecified
macOS
defect

Tracking

()

REOPENED
Tracking Status
firefox66 --- unaffected
firefox67 --- affected

People

(Reporter: marcia, Unassigned)

Details

(Keywords: crash, regression)

Crash Data

This bug is for crash report bp-69de2e2a-5bdc-491d-bfe4-3481f0190313.

Seen while looking at nightly crash stats - lone crash so far on https://firefox-dev.tools/debugger-examples/examples/todomvc/.

Brian - Please let me know if this is useful to file bugs such as this even if it is a single crash. Thanks.

Top 10 frames of crashing thread:

0 XUL mozilla::recordreplay::FreeRegionSet::ExtractLockHeld toolkit/recordreplay/MemorySnapshot.cpp:556
1 XUL mozilla::recordreplay::FreeRegionSet::Extract toolkit/recordreplay/MemorySnapshot.cpp:1020
2 XUL mozilla::recordreplay::AllocateMemoryTryAddress toolkit/recordreplay/MemorySnapshot.cpp:1112
3 XUL mozilla::recordreplay::Preamble_mmap toolkit/recordreplay/ProcessRedirectDarwin.cpp:443
4 XUL mozilla::recordreplay::CallPreambleHook toolkit/recordreplay/ProcessRedirect.cpp:35
5 XUL RecordReplayInterceptCall toolkit/recordreplay/ProcessRedirect.cpp:62
6 XUL RecordReplayRedirectCall_Loop 
7 libmozglue.dylib arena_t::PallocHuge memory/build/mozjemalloc.cpp:3560
8 libmozglue.dylib BaseAllocator::calloc memory/build/mozjemalloc.cpp:3537
9 libmozglue.dylib Allocator<MozJemallocBase>::calloc memory/build/malloc_decls.h:39

Thanks for filing bugs like this, it's very helpful for keeping track of the different crashes that are happening.

Priority: -- → P5

Closing because no crashes reported for 12 weeks.

Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → WORKSFORME

Bugbug thinks this bug is a regression, but please revert this change in case of error.

Keywords: regression

Reopening as there are some recent crashes, including some in the 11-11 build.

Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
You need to log in before you can comment on or make changes to this bug.