Intermittent 415 INFO TEST-UNEXPECTED-FAIL | | /tests/toolkit/components/passwordmgr/test/mochitest/test_one_doorhanger_per_un_pw.html - finished in a non-clean fashion, probably because it didn't call SimpleTest.finish()

RESOLVED FIXED in Firefox 67

Status

()

defect
P2
normal
RESOLVED FIXED
2 months ago
25 days ago

People

(Reporter: intermittent-bug-filer, Assigned: prathiksha)

Tracking

(Depends on 1 bug, {intermittent-failure, regression})

unspecified
mozilla67
Points:
---
Dependency tree / graph
Bug Flags:
qe-verify -

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox65 unaffected, firefox66 unaffected, firefox67 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 months ago
treeherder

#[markdown(off)]
Filed by: btara [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=233691777&repo=autoland

https://queue.taskcluster.net/v1/task/Y_strLIRSlCF1w_luMfFfg/runs/0/artifacts/public/logs/live_backing.log

[task 2019-03-13T20:40:22.134Z] 20:40:22 INFO - 403 INFO TEST-START | toolkit/components/passwordmgr/test/mochitest/test_one_doorhanger_per_un_pw.html
[task 2019-03-13T20:40:32.355Z] 20:40:32 INFO - 404 INFO TEST-OK | toolkit/components/passwordmgr/test/mochitest/test_one_doorhanger_per_un_pw.html | took 9129ms
[task 2019-03-13T20:40:32.357Z] 20:40:32 INFO - 405 INFO TEST-START | Shutdown
[task 2019-03-13T20:40:32.357Z] 20:40:32 INFO - 406 INFO Passed: 6
[task 2019-03-13T20:40:32.357Z] 20:40:32 INFO - 407 INFO Failed: 0
[task 2019-03-13T20:40:32.357Z] 20:40:32 INFO - 408 INFO Todo: 1
[task 2019-03-13T20:40:32.357Z] 20:40:32 INFO - 409 INFO Mode: non-e10s
[task 2019-03-13T20:40:32.357Z] 20:40:32 INFO - 410 INFO Slowest: 9127ms - /tests/toolkit/components/passwordmgr/test/mochitest/test_one_doorhanger_per_un_pw.html
[task 2019-03-13T20:40:32.357Z] 20:40:32 INFO - 411 INFO SimpleTest FINISHED
[task 2019-03-13T20:40:33.976Z] 20:40:33 INFO - Failed to get top activity, retrying, once...
[task 2019-03-13T20:42:17.365Z] 20:42:17 INFO - 412 INFO TEST-PASS | unknown test url | A valid string reason is expected
[task 2019-03-13T20:42:17.366Z] 20:42:17 INFO - 413 INFO TEST-PASS | unknown test url | Reason cannot be empty
[task 2019-03-13T20:42:17.367Z] 20:42:17 INFO - 414 INFO TEST-UNEXPECTED-FAIL | unknown test url | uncaught exception - TypeError: SimpleTest.harnessParameters is undefined at SimpleTest_setTimeoutShim@https://example.com/tests/SimpleTest/SimpleTest.js:669:17
[task 2019-03-13T20:42:17.368Z] 20:42:17 INFO - add_task@https://example.com/tests/SimpleTest/AddTask.js:30:7
[task 2019-03-13T20:42:17.368Z] 20:42:17 INFO - @https://example.com/tests/toolkit/components/passwordmgr/test/mochitest/test_one_doorhanger_per_un_pw.html:44:3
[task 2019-03-13T20:42:17.368Z] 20:42:17 INFO - simpletestOnerror@https://example.com/tests/SimpleTest/SimpleTest.js:1665:24
[task 2019-03-13T20:42:19.700Z] 20:42:19 INFO - 415 INFO TEST-UNEXPECTED-FAIL | | /tests/toolkit/components/passwordmgr/test/mochitest/test_one_doorhanger_per_un_pw.html - finished in a non-clean fashion, probably because it didn't call SimpleTest.finish()
[task 2019-03-13T20:42:19.701Z] 20:42:19 INFO - {u'loaded_test_url': u'/tests/toolkit/components/passwordmgr/test/mochitest/test_one_doorhanger_per_un_pw.html'}
[task 2019-03-13T20:42:19.701Z] 20:42:19 INFO - 416 INFO TEST-UNEXPECTED-ERROR | | Finished in 11415ms
[task 2019-03-13T20:42:19.701Z] 20:42:19 INFO - {u'runtime': 11415}
[task 2019-03-13T20:42:19.701Z] 20:42:19 INFO - TEST-INFO
[task 2019-03-13T20:42:20.413Z] 20:42:20 INFO - 417 INFO SimpleTest START
[task 2019-03-13T20:42:20.414Z] 20:42:20 INFO - 418 INFO TEST-START | toolkit/components/passwordmgr/test/mochitest/test_one_doorhanger_per_un_pw.html
[task 2019-03-13T20:42:31.538Z] 20:42:31 INFO - wait for org.mozilla.fennec_aurora complete; top activity=com.android.launcher
[task 2019-03-13T20:42:31.743Z] 20:42:31 INFO - remoteautomation.py | Application ran for: 0:03:15.103899
[task 2019-03-13T20:42:32.463Z] 20:42:32 INFO - Stopping web server
[task 2019-03-13T20:42:32.467Z] 20:42:32 INFO - Stopping web socket server
[task 2019-03-13T20:42:32.488Z] 20:42:32 INFO - Stopping ssltunnel
[task 2019-03-13T20:42:32.508Z] 20:42:32 INFO - leakcheck | refcount logging is off, so leaks can't be detected!
[task 2019-03-13T20:42:32.508Z] 20:42:32 INFO - runtests.py | Running tests: end.

(Assignee)

Updated

2 months ago
Depends on: 1535505
Assignee: nobody → prathikshaprasadsuman
Status: NEW → ASSIGNED
Priority: P5 → P2

Comment 3

2 months ago
Pushed by mozilla@noorenberghe.ca:
https://hg.mozilla.org/integration/autoland/rev/ec0fcbde84b9
Disable test_one_doorhanger_per_un_pw.html on android until the internmittent failures are fixed. r=MattN

Comment 4

2 months ago
bugherder
Status: ASSIGNED → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67
Comment hidden (Intermittent Failures Robot)
(Assignee)

Updated

2 months ago
Flags: needinfo?(prathikshaprasadsuman)
Flags: needinfo?(btara)

@Bogdan: Can you help me verify this bug? Is it verifiable before its bug 1535505 is fixed?

@Bogdan: Can you help me verify this bug? Is it verifiable before its bug 1535505 is fixed?

:danibodea as far as i can tell, this hasn't popped on our radar after the patch has landed. There's no patch on 1535505, so, i'd say that this would still happen in case the test disable would be backed out.

You could do a push to try (with ec0fcbde84b9 backed out), to check if the issue was fixed without a direct fix being push via 1535505.

Flags: needinfo?(btara)

I don't have the necessary technical skills to do what's mentioned in comment 8. I'd appreciate if you could help with this verification. This bug is related to a current feature implementation. What do you think it would be the best course of action in this case? Thank you.

Flags: needinfo?(btara)
Flags: needinfo?(btara)

Is the test incorrect or is there something wrong with the build?

Flags: needinfo?(btara)

As seen in my push to try, test_one_doorhanger_per_un_pw.html still fails, so it wasn't fixed, as far as i can understand.

https://treeherder.mozilla.org/#/jobs?repo=try&revision=c6c7b76aa37407cf25777382c49335ade9839196&selectedJob=238440732

Flags: needinfo?(btara)
You need to log in before you can comment on or make changes to this bug.