Closed Bug 1535242 Opened 1 year ago Closed 1 year ago

Provide better message when choosing a directory to clone.

Categories

(Firefox Build System :: General, defect, P5)

defect

Tracking

(firefox68 fixed)

RESOLVED FIXED
mozilla68
Tracking Status
firefox68 --- fixed

People

(Reporter: arai, Assigned: arai)

References

Details

Attachments

(1 file)

While running bootstrap.py outside the repository, it offers cloning.

If you would like to clone the mozilla-unified Mercurial repository, please
enter the destination path below.

Destination directory for Mercurial clone (leave empty to not clone): /tmp/non-empty
ERROR! Destination directory '/tmp/non-empty' is not empty.

Would you like to clone to '/tmp/non-empty/mozilla-unified'?

  1. Yes
  2. No, let me enter another path
  3. No, stop cloning

Please enter your reply: 2
Destination directory for Mercurial clone (leave empty to not clone): /tmp/contains-with-mozilla-unified

ERROR! Destination directory '/tmp/contains-with-mozilla-unified' is not empty.

I got feedback about the first ERROR! that it doesn't sounds like error but warning.
surely, it's most likely a not erroneous case but just that the user supposed that the question is about the directory where the mozilla-unified subdirectory is created.
so it's better using WARNING, or just omit it.

Then also the 2nd case doesn't say what the issue is.
it should say that mozilla-unified exists there.

  • Do not use ERROR when user enters possibly parent-directory when
    choosing the directory to clone mozilla-unified
  • Show the path of pre-existing mozilla-unified path on error
Pushed by arai_a@mac.com:
https://hg.mozilla.org/integration/autoland/rev/8f7dde1eb085
Provide better message when choosing a directory to clone. r=glandium
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
You need to log in before you can comment on or make changes to this bug.