Closed Bug 1535243 Opened 1 year ago Closed 1 year ago

Provide reference for mercurial bundle when hg pull fails in bootstrap

Categories

(Firefox Build System :: Bootstrap Configuration, defect, P5)

defect

Tracking

(firefox68 fixed)

RESOLVED FIXED
mozilla68
Tracking Status
firefox68 --- fixed

People

(Reporter: arai, Assigned: arai)

Details

Attachments

(1 file)

https://searchfox.org/mozilla-central/rev/aae527894a97ee3bbe0c2cfce9c67c59e8b8fcb9/python/mozboot/mozboot/bootstrap.py#633

bootstrap offers cloning mozilla-unified
if it fails, it's most likely because of network issue (instability, maybe because of WiFi, or just bandwidth),
and it's likely that doing hg clone or hg pull again will fail again with the same reason.

it should be better providing a reference to mercurial bundle.
(it's frequent to see newcomers bumps into this issue)

hg pull from an empty hg repository, which is what bootstrap is doing, already uses the mercurial bundle, though...

This feels like something that should be filed against mercurial itself.

(In reply to Mike Hommey [:glandium] from comment #1)

hg pull from an empty hg repository, which is what bootstrap is doing, already uses the mercurial bundle, though...

This feels like something that should be filed against mercurial itself.

Yes, the problem is about the mercurial's network's robustness against network issue I think,
and quick workaround is to use better downloader.

Assignee: nobody → arai.unmht
Status: NEW → ASSIGNED
Pushed by arai_a@mac.com:
https://hg.mozilla.org/integration/autoland/rev/da0f31d8e52c
Provide reference for mercurial bundle when hg pull fails in bootstrap. r=glandium
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
You need to log in before you can comment on or make changes to this bug.