Clearing Site Data fails with LSNG if the user has quota storage for about:pages

VERIFIED FIXED in Firefox 68

Status

()

defect
P1
normal
VERIFIED FIXED
3 months ago
4 days ago

People

(Reporter: johannh, Assigned: tt)

Tracking

(Blocks 2 bugs, {regression})

unspecified
mozilla68
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox66 unaffected, firefox67 disabled, firefox68+ verified)

Details

Attachments

(1 attachment)

Reporter

Description

3 months ago

I was trying to remove individual site data in about:preferences -> Cookies and Site Data -> Manage Data and it failed with this error:

NS_ERROR_FAILURE: Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIURI.host]

This is because https://searchfox.org/mozilla-central/rev/aae527894a97ee3bbe0c2cfce9c67c59e8b8fcb9/toolkit/components/cleardata/ClearDataService.jsm#386 is accessing the .host attribute of about:newtab, in my case.

At the very least we should filter out about: URIs here, but I'm also wondering what this entire block's purpose is:

https://searchfox.org/mozilla-central/rev/aae527894a97ee3bbe0c2cfce9c67c59e8b8fcb9/toolkit/components/cleardata/ClearDataService.jsm#370-403

I'm pretty sure that this comment is not accurate. Jan, do you remember why this was done?

[Tracking Requested - why for this release]:
Most users can't remove individual site data anymore.

Flags: needinfo?(jvarga)

Tracking for 67, it would be good to have a fix before the merge to beta next Monday.

Updated

3 months ago
Blocks: 1517090
No longer blocks: 1286798
Flags: needinfo?(jvarga)

Updated

3 months ago
Flags: needinfo?(jvarga)

Updated

3 months ago
Duplicate of this bug: 1538671

Comment 3

3 months ago

Selected storage items appear to be removed from disk in my experience, the Manage Cookies and Site Data panel doesn't close though which is confusing and the preferences page has to be refreshed to see the changes.

Updated

3 months ago
No longer blocks: 1517090

Updated

3 months ago
Blocks: 1540402

Comment 4

2 months ago

Yes, this is on our radar.

Flags: needinfo?(jvarga)
Reporter

Updated

2 months ago
Duplicate of this bug: 1541439

I ma moving the tracking flag to 68 as LSNG won't ship in 67.

Tom, can you take this bug?

Flags: needinfo?(shes050117)
Assignee

Comment 8

2 months ago

Sure

Assignee: nobody → shes050117
Status: NEW → ASSIGNED
Flags: needinfo?(shes050117)
Assignee

Comment 9

Last month

Note that the internal origins like "about:xxx" won't be collected by listInitializedOrigins() so the minimum requirement has been down.

I'm looking into the behavior of Cookie and Quota stuff. They should be removed together while removing any given origins.

Assignee

Comment 10

Last month

(In reply to Tom Tung [:tt, :ttung] from comment #9)

Note that the internal origins like "about:xxx" won't be collected by listInitializedOrigins() so the minimum requirement has been down.

In fact, about:newtab doesn't be treated as an internal origin now.

Attachment #9062461 - Attachment description: Bug 1535298 - Avoid the principal without a host and check if the originAttribute matches; → Bug 1535298 - Avoid checking the host from a principal without that attribute and check if the originAttribute matches;
Assignee

Updated

Last month
Blocks: 1551552
Attachment #9062461 - Attachment description: Bug 1535298 - Avoid checking the host from a principal without that attribute and check if the originAttribute matches; → Bug 1535298 - Capture and ignore the exception for not having a host from a principal;
Attachment #9062461 - Attachment description: Bug 1535298 - Capture and ignore the exception for not having a host from a principal; → Bug 1535298 - Capture and ignore the exception for not having a host from a principal URI;

Comment 12

Last month
Pushed by shes050117@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/9437ce7f56f1
Capture and ignore the exception for not having a host from a principal URI; r=janv,johannh
Status: ASSIGNED → RESOLVED
Closed: Last month
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
Assignee

Comment 14

Last month

Hi Kestrel,

Would you mind helping me to verify if the problem is fixed by testing the latest Nightly? It works on my laptop and I believe the problem is resolved.

Flags: needinfo?(ke5trel)

Comment 15

Last month

I can verify this is fixed on Nightly 68.0a1 (2019-05-14) using a profile that has about:newtab storage, the Manage Cookies and Site Data dialog correctly closes after removing a storage item and there is no error in browser console.

Status: RESOLVED → VERIFIED
Flags: needinfo?(ke5trel)
Assignee

Comment 16

Last month

(In reply to Kestrel from comment #15)

I can verify this is fixed on Nightly 68.0a1 (2019-05-14) using a profile that has about:newtab storage, the Manage Cookies and Site Data dialog correctly closes after removing a storage item and there is no error in browser console.

Thanks!

You need to log in before you can comment on or make changes to this bug.