[PP] Can't get focus in Pref UI

VERIFIED FIXED in M10

Status

defect
P2
normal
VERIFIED FIXED
20 years ago
15 years ago

People

(Reporter: paulmac, Assigned: pavlov)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Reporter

Description

20 years ago
I am unable to get focus in the Pref UI using the 100108 Linux M11 build. The
only way to close it is to the the X in the upper right hand corner, and you
can't modify any Prefs at all. To reproduce:

1. Open up Preferences via the Edit menu.
2. Try clicking anywhere in the PrefUI

Results: Nothing happens. You must close Prefs with the X.

This does not occur on Windows build. Mac not tested. Marking PP.
Reporter

Updated

20 years ago
Assignee: matt → pavlov
Reporter

Comment 1

20 years ago
This seems more of a general Linux issue. I'm having the same problems getting
focus on password dialogues also. Can't click OK on them either. Will try pavlov
on this one :-)
Reporter

Comment 2

20 years ago
An easy way to duplicate the password focus issue:
1. Goto slip/projects/marvin/wallet/login.html
2. Enter a signon and click Login
3. Enter password, and again when prompted
4. Goto Edit - Wallet - Change Password

Results: You cannot get focus on the change password dialogue and must click on
the X to close it.

Comment 3

20 years ago
*** Bug 15362 has been marked as a duplicate of this bug. ***

Updated

20 years ago
Priority: P3 → P2
Target Milestone: M11

Comment 4

20 years ago
This is hindering pref work.
Reporter

Comment 5

20 years ago
This is in the M10 builds. Do we really want to ship M10 with this nastiness?

Comment 6

20 years ago
modeless prefs dialog would workaround this problem :-)
posting a patch.

Updated

20 years ago
Target Milestone: M11 → M10

Comment 8

20 years ago
Putting on m10 radar so we can think about this for m10.
Assignee

Comment 9

20 years ago
was this fixed today.. err.. yesterday?  (i really should sleep) by danm's
checkin?

Updated

20 years ago
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED

Comment 10

20 years ago
danm has checked in a fix for bug 15596 to the m10 branch.
should appear in the next respin
Reporter

Updated

20 years ago
Status: RESOLVED → VERIFIED
Reporter

Comment 11

20 years ago
verified

Comment 12

20 years ago
Bulk move of all Pref UI component bugs to new Preferences component.  Pref UI 
component will be deleted.
Component: Pref UI → Preferences
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.