Don't set prefs inside browser_blockingServiceWorkers.js

RESOLVED FIXED in Firefox 67

Status

()

enhancement
RESOLVED FIXED
2 months ago
2 months ago

People

(Reporter: Ehsan, Assigned: Ehsan)

Tracking

unspecified
mozilla67
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox67 fixed)

Details

Attachments

(3 attachments)

This is a promise chain which doesn't exist in the other browser_blocking*.js tests, which may be the cause behind the intermittent failure in bug 1498102.

Comment 4

2 months ago
Pushed by eakhgari@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7eed7ef4c16e
Part 1: Don't pass an extra argument to AntiTracking._setupTest(); r=baku
https://hg.mozilla.org/integration/autoland/rev/81d4d461ab15
Part 2: Don't clobber the extraPrefs argument when calling AntiTracking._createTask(); r=baku
https://hg.mozilla.org/integration/autoland/rev/3c2169f7665e
Part 3: Don't set prefs inside browser_blockingServiceWorkers.js from the content process and just pass them through extraPrefs; r=baku

Comment 5

2 months ago
bugherder
Status: NEW → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67
Assignee: nobody → ehsan
You need to log in before you can comment on or make changes to this bug.