If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

email with no LF is not wordwrapped correctly when replying

VERIFIED DUPLICATE of bug 20240

Status

MailNews Core
Composition
VERIFIED DUPLICATE of bug 20240
16 years ago
9 years ago

People

(Reporter: jg, Assigned: Jean-Francois Ducarroz)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020605
BuildID:    2002060511

email with no LF is not wordwrapped correctly when replying

Reproducible: Always
Steps to Reproduce:
1.get an email with all text on one line >72 characters, my example uses 220
chars on one line 
2.reply to the message, look at the composition/reply window
3.

Actual Results:  text is liek this

Rxxxxxxxxt@jxxxjp wrote:
> HIxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx really really long line 220chars
>

composition window thus has a really long horizontal scrole bar at the  bottom
of the window

Expected Results:  reply should cut the email into 72char line segments as
defined in Preferences -> Message composition (note that 72char lines shhould
incluide "> " so only 70chars left for text and should be wrapped at the last
space char in between words unless there is <1 space char's in the first 70 chars)

72chars is the default, and i use the default.

NB, Forward wordwrap works correctly (sans > comment though)
Is this the same as bug 20240?
(Reporter)

Comment 2

16 years ago
> ------- Additional Comments From mvl@shop-engine.nl  2002-06-22 02:59 -------
> Is this the same as bug 20240?

hi,
yes it is, is there a reason why this is the defined behaviour? it seems
incorrect to me IMO.

JG

Comment 3

15 years ago
Duping then. The behavior is correct since there might be a good reason for the
long lines, e.g. it has structure as code or shows some kind of table, ASCII art
and stuff.

pi

*** This bug has been marked as a duplicate of 20240 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 4

14 years ago
v
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.