Closed Bug 1535441 Opened 1 year ago Closed 1 year ago

Update Windows clang to 8.0.0final

Categories

(Firefox Build System :: Toolchains, defect)

defect
Not set

Tracking

(firefox67 fixed, firefox68 fixed)

RESOLVED FIXED
mozilla68
Tracking Status
firefox67 --- fixed
firefox68 --- fixed

People

(Reporter: dmajor, Assigned: dmajor)

References

Details

Attachments

(1 file, 1 obsolete file)

47 bytes, text/x-phabricator-request
Details | Review

It's expected that rc5 will be the final contents of the 8.0.0 release. It would be nice to get this in before the merge and not have to bother with an uplift.

It's expected that rc5 will be the final contents of the 8.0.0 release.

Attachment #9051105 - Attachment is obsolete: true
Summary: Update Windows clang to 8.0.0rc5 → Update Windows clang to 8.0.0final

This gets us back to using an official release.

Pushed by dmajor@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ca91ac220ca9
Update win64 clang-cl to 8.0.0final r=firefox-build-system-reviewers,chmanchester
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68

We want to uplift this, right?

Flags: needinfo?(dmajor)

Comment on attachment 9052067 [details]
Update win64 clang-cl to 8.0.0final

Beta/Release Uplift Approval Request

  • Feature/Bug causing the regression: None
  • User impact if declined: Ship with a prerelease compiler
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Moves us from a release candidate build of clang to the official release. Gives us better confidence because it's gone through more validation more people are using it, etc.
  • String changes made/needed: None
Flags: needinfo?(dmajor)
Attachment #9052067 - Flags: approval-mozilla-beta?

Comment on attachment 9052067 [details]
Update win64 clang-cl to 8.0.0final

Building with the final release of Clang instead of an RC makes sense, uplift approved for 67 beta 6, thanks.

Attachment #9052067 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Flags: qe-verify-
You need to log in before you can comment on or make changes to this bug.