Closed Bug 1535561 Opened 4 years ago Closed 3 years ago

[CSD][Wayland] Some buttons stop working and page content stops rendering after restoring window from minimized state

Categories

(Core :: Widget: Gtk, defect, P3)

Unspecified
Linux
defect

Tracking

()

RESOLVED DUPLICATE of bug 1572455

People

(Reporter: ke5trel, Unassigned)

References

(Blocks 2 open bugs)

Details

STR:

  1. Start Firefox with GDK_BACKEND=wayland on Ubuntu 18.10.
  2. Minimize window and restore it.
  3. Try to minimize again and switch tabs.

The minimize button, hamburger button and library button stop working, most other buttons still work. Switch tabs and the page content is empty and not being rendered for remote content. Have to maximize/restore window to get everything working again.

Does not happen with system titlebar enabled (CSD disabled) and mozilla.widget.use-argb-visuals = true/false makes no difference. Reproducible going back to 2018-12-01 build at least so not a recent regression.

Can confirm the bug.

It is easily reproducible every time you minimize the firefox, in addition tabs fail to render after switching them after maximizing the window. Seems like the only major bug until Firefox is completely usable under wayland...

Priority: -- → P3

Ubuntu 18.10 is not our Wayland target as it misses important popup fixes in Gtk/compositor. There's no point to fixing Wayland on such old environment.

Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX

Ubuntu 19.04 is affected.

Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---

I see it on Arch Linux, at least with the Arc GTK theme. The minimize and maximize buttons don't work until restore, but there's no rendering issue with the tabs.

I still see the rendering issue with remote tabs on latest Nightly (Ubuntu 19.04) after restoring a minimized window, the tab that was active when minimized is unaffected but other tabs fail to render until the window is maximized.

Can confirm that bug is still present on Ubuntu 19.04.

I have this problem as well. Manjaro Unstable Gnome.
Problem exists in Firefox Developer and Fedora Firefox Wayland from AUR.
I normally get around 10-15 minutes of normal operation, then it is totally unusable.

Also can confirm this bug occurring in Firefox 68 running on Fedora 29. Temporary workaround is to save browser session and restore it in a new window without closing or killing any Firefox process. After that, previous window can be closed and browsing the internet can continue normally.

Please try again with webrender disabled....I suspect it may be related. Thanks.

Flags: needinfo?(ke5trel)

gfx.webrender.all ?? = false here.

Browser functions correctly as stated above is the titlebar is visible.

(In reply to Martin Stránský [:stransky] from comment #9)

Please try again with webrender disabled....I suspect it may be related. Thanks.

Compositor is unrelated, it happens with Basic, OpenGL and WebRender.

Flags: needinfo?(ke5trel)

Same here, gfx.webrender.all = false already.

Fixed in latest Nightly by Bug 1572455.

Status: REOPENED → RESOLVED
Closed: 3 years ago3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1572455

I am still getting the problem in FF dev, but it takes a lot longer to manifest.

Version 69.0b12-1

(In reply to xirconuk@gmail.com from comment #14)

I am still getting the problem in FF dev, but it takes a lot longer to manifest.

Version 69.0b12-1

Issue is supposedly solved in Firefox 70 nightly, not 69, I can confirm that I haven't run across that bug on 70 nightly anymore :)

You need to log in before you can comment on or make changes to this bug.