Reply to Markdown comment adds extra line above quoted text but not below

RESOLVED FIXED

Status

()

defect
RESOLVED FIXED
3 months ago
Last month

People

(Reporter: wsmwk, Assigned: kohei)

Tracking

(Blocks 1 bug, {regression})

Production
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Reporter

Description

3 months ago

+++ This bug was initially created as a clone of Bug #1535521 +++

Problem: text without blank line after quoted material is rendered smashed together with the quoted material, but in email and in BMO page rendering.

Solution: Don't smash reply into the quote. If a blank line is required to make this work, then the "reply" function should supply it, we should not make the user put it in.

But it would be better IMO to render nicely when there is no blank line after the "quote".

Compare these two cases. The first one is made to look like there is no reply.

(In reply to Kohei Yoshino [:kohei] (Bugzilla UX) (FxSiteCompat) from comment #11)

Hey abusers, I listen to you 🤗
No you don't

(In reply to Kohei Yoshino [:kohei] (Bugzilla UX) (FxSiteCompat) from comment #11)

Hey abusers, I listen to you 🤗

No you don't

Reporter

Comment 1

3 months ago

example email. And same as apperance in BMO web page.

(I am joking of course about "you don't listen". Reality is just the opposite.)

Reporter

Comment 2

2 months ago

bug 1532962 comment 5 is an example

Severity: minor → normal
Flags: needinfo?(kohei.yoshino)

Should be easy to fix.

Assignee: nobody → kohei.yoshino
Blocks: bmo-markdown
Status: NEW → ASSIGNED
Flags: needinfo?(kohei.yoshino)
Duplicate of this bug: 1535521
Summary: text without blank line after quoted material is rendered smashed together with the quoted material → Reply to Markdown comment add extra line above quoted text but not below
Summary: Reply to Markdown comment add extra line above quoted text but not below → Reply to Markdown comment adds extra line above quoted text but not below

Merged to master.

Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Reporter

Comment 7

Last month

Something's not quite right. And very strange because I don't remember seeing this before today.

When I click the reply arrow, there is still a line above the quoted material. And now the cursor is after the last character of the quoted material

Flags: needinfo?(kohei.yoshino)

We haven’t pushed this to production yet.

Flags: needinfo?(kohei.yoshino)

Should be live next week :)

You need to log in before you can comment on or make changes to this bug.