Closed Bug 1535598 Opened 4 years ago Closed 4 years ago

Intermittent testing/marionette/harness/marionette_harness/tests/unit/test_navigation.py TestBackForwardNavigation.test_frameset_after_navigating_in_frame | TimeoutException: Timed out after 300.1 seconds with message:Target element 'email' has not been f

Categories

(Testing :: Marionette, defect, P5)

Version 3
ARM64
Android
defect

Tracking

(firefox-esr60 unaffected, firefox67 wontfix, firefox67.0.1 wontfix, firefox68 fixed, firefox69 fixed)

RESOLVED FIXED
mozilla69
Tracking Status
firefox-esr60 --- unaffected
firefox67 --- wontfix
firefox67.0.1 --- wontfix
firefox68 --- fixed
firefox69 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: whimboo)

References

Details

(Keywords: intermittent-failure, mobile, regression)

#[markdown(off)]
Filed by: opoprus [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=234100194&repo=mozilla-central

https://queue.taskcluster.net/v1/task/DEBfAZ_pRWq4Z_G2xwYZQA/runs/0/artifacts/public/logs/live_backing.log

[task 2019-03-15T10:51:54.617Z] 10:51:54 INFO - TEST-START | testing/marionette/harness/marionette_harness/tests/unit/test_navigation.py TestBackForwardNavigation.test_frameset_after_navigating_in_frame
[task 2019-03-15T10:56:56.003Z] 10:56:56 WARNING - TEST-UNEXPECTED-ERROR | testing/marionette/harness/marionette_harness/tests/unit/test_navigation.py TestBackForwardNavigation.test_frameset_after_navigating_in_frame | TimeoutException: Timed out after 300.1 seconds with message: Target element 'email' has not been found
[task 2019-03-15T10:56:56.003Z] 10:56:56 INFO - Traceback (most recent call last):
[task 2019-03-15T10:56:56.003Z] 10:56:56 INFO - File "/builds/worker/workspace/build/venv/lib/python2.7/site-packages/marionette_harness/marionette_test/testcases.py", line 159, in run
[task 2019-03-15T10:56:56.003Z] 10:56:56 INFO - testMethod()
[task 2019-03-15T10:56:56.003Z] 10:56:56 INFO - File "/builds/worker/workspace/build/tests/marionette/tests/testing/marionette/harness/marionette_harness/tests/unit/test_navigation.py", line 471, in test_frameset_after_navigating_in_frame
[task 2019-03-15T10:56:56.003Z] 10:56:56 INFO - message="Target element 'email' has not been found")
[task 2019-03-15T10:56:56.003Z] 10:56:56 INFO - File "/builds/worker/workspace/build/venv/lib/python2.7/site-packages/marionette_driver/wait.py", line 154, in until
[task 2019-03-15T10:56:56.003Z] 10:56:56 INFO - cause=last_exc)
[task 2019-03-15T10:56:56.003Z] 10:56:56 INFO - TEST-INFO took 301386ms

Keywords: mobile
OS: Unspecified → Android
Hardware: Unspecified → ARM64

Here an excerpt from the android logcat:

05-18 22:14:46.876 2373 2389 I Gecko : 1558214086876 Marionette DEBUG 497 -> [0,24,"WebDriver:FindElement",{"using":"id","value":"linkId"}]
05-18 22:14:46.877 2373 2389 I Gecko : 1558214086877 Marionette DEBUG 497 <- [1,24,null,{"value":{"element-6066-11e4-a52e-4f735466cecf":"77cd54cd-aaca-4b38-8426-f34f170a4607"}}]
05-18 22:14:46.878 2373 2389 I Gecko : 1558214086878 Marionette DEBUG 497 -> [0,25,"WebDriver:ElementClick",{"id":"77cd54cd-aaca-4b38-8426-f34f170a4607"}]
05-18 22:14:47.395 2373 2373 D GeckoToolbar: onTabChanged: THUMBNAIL
05-18 22:14:47.395 2373 2373 D GeckoBrowserApp: BrowserApp.onTabChanged: 8: THUMBNAIL
05-18 22:14:47.395 2373 2389 I Gecko : 1558214087395 Marionette WARN TimedPromise timed out after 500 ms: stacktrace:
05-18 22:14:47.395 2373 2389 I Gecko : bail@chrome://marionette/content/sync.js:223:64
05-18 22:14:47.609 2373 2389 I Gecko : 1558214087609 Marionette DEBUG [363] Canceled page load listener because no navigation has been detected
05-18 22:14:47.610 2373 2389 I Gecko : 1558214087610 Marionette DEBUG 497 <- [1,25,null,{"value":null}]
05-18 22:14:47.610 2373 2389 I Gecko : 1558214087610 Marionette DEBUG 497 -> [0,26,"WebDriver:GetTimeouts",{}]
05-18 22:14:47.611 2373 2389 I Gecko : 1558214087611 Marionette DEBUG 497 <- [1,26,null,{"implicit":0,"pageLoad":300000,"script":30000}]
05-18 22:14:47.611 2373 2389 I Gecko : 1558214087611 Marionette DEBUG 497 -> [0,27,"WebDriver:FindElement",{"using":"id","value":"email"}]
05-18 22:14:47.612 2373 2389 I Gecko : 1558214087612 Marionette DEBUG 497 <- [1,27,{"error":"no such element","message":"Unable to locate element: email","stacktrace":"WebDriverError@chrome://marionette ... entError@chrome://marionette/content/error.js:389:5\nelement.find/</<@chrome://marionette/content/element.js:339:16\n"},null]

As it can be seen we were trying to click the link, but no navigation has been taken place within 500ms. As such the target element of the expected new page isn't present.

In the last 7 days there have been 42 occurrences on Andoid 7 32 Opt.

The rate of failures actually went down drastically the last days. I will keep an eye on it and will re-check by next Monday.

No more failures on trunk. Most likely this was fixed with my patch on bug 1335085.

Status: NEW → RESOLVED
Closed: 4 years ago
Depends on: 1335085
Resolution: --- → FIXED
Target Milestone: --- → mozilla69
Assignee: nobody → hskupin

Seeing this on beta:
https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=252198473&repo=mozilla-beta&lineNumber=2387

[task 2019-06-17T17:40:04.061Z] 17:40:04 INFO - TEST-START | testing/marionette/harness/marionette_harness/tests/unit/test_navigation.py TestBackForwardNavigation.test_frameset
[task 2019-06-17T17:40:05.593Z] 17:40:05 INFO - TEST-PASS | testing/marionette/harness/marionette_harness/tests/unit/test_navigation.py TestBackForwardNavigation.test_frameset | took 1531ms
[task 2019-06-17T17:40:05.799Z] 17:40:05 INFO - TEST-START | testing/marionette/harness/marionette_harness/tests/unit/test_navigation.py TestBackForwardNavigation.test_frameset_after_navigating_in_frame
[task 2019-06-17T17:45:07.097Z] 17:45:07 WARNING - TEST-UNEXPECTED-ERROR | testing/marionette/harness/marionette_harness/tests/unit/test_navigation.py TestBackForwardNavigation.test_frameset_after_navigating_in_frame | TimeoutException: Timed out after 300.1 seconds with message: Target element 'email' has not been found
[task 2019-06-17T17:45:07.097Z] 17:45:07 INFO - Traceback (most recent call last):
[task 2019-06-17T17:45:07.097Z] 17:45:07 INFO - File "/builds/worker/workspace/build/venv/lib/python2.7/site-packages/marionette_harness/marionette_test/testcases.py", line 159, in run
[task 2019-06-17T17:45:07.097Z] 17:45:07 INFO - testMethod()
[task 2019-06-17T17:45:07.097Z] 17:45:07 INFO - File "/builds/worker/workspace/build/tests/marionette/tests/testing/marionette/harness/marionette_harness/tests/unit/test_navigation.py", line 471, in test_frameset_after_navigating_in_frame
[task 2019-06-17T17:45:07.097Z] 17:45:07 INFO - message="Target element 'email' has not been found")
[task 2019-06-17T17:45:07.097Z] 17:45:07 INFO - File "/builds/worker/workspace/build/venv/lib/python2.7/site-packages/marionette_driver/wait.py", line 154, in until
[task 2019-06-17T17:45:07.097Z] 17:45:07 INFO - cause=last_exc)
[task 2019-06-17T17:45:07.097Z] 17:45:07 INFO - TEST-INFO took 301297ms

Hi Henrik, this is still ongoing on mozilla-beta: https://treeherder.mozilla.org/#/jobs?repo=mozilla-beta&selectedJob=254134544&resultStatus=testfailed%2Cbusted%2Cexception

Should we file a new bug or reopen this one?

Flags: needinfo?(hskupin)

Please file a new bug. It could be something different. Thanks.

Flags: needinfo?(hskupin)
You need to log in before you can comment on or make changes to this bug.