Closed Bug 1535656 Opened 1 year ago Closed 1 year ago

Quantum bar results flicker while typing a search

Categories

(Firefox :: Address Bar, defect, P2)

defect
Points:
5

Tracking

()

VERIFIED FIXED
Firefox 68
Iteration:
68.3 - Apr 15 - 28
Tracking Status
firefox68 --- verified

People

(Reporter: dthayer, Assigned: mak)

References

(Blocks 1 open bug)

Details

Attachments

(2 files, 1 obsolete file)

Right now, with browser.urlbar.quantumbar enabled, when typing out a search string, the results flicker in and out. This is unnecessarily noisy, and rather distracting. Compare to the same operation in Chrome, and with browser.urlbar.quantumbar off - the results do not get removed until new results are in.

Blocks: 1512667
Depends on: 1523602
Priority: -- → P2

from bug 1523602 comment 3:

Another detail that is not documented about the legacy urlbar: we distinguish results coming from the network from local results, because they have different characteristics.

For example, we put search suggestions before historical results, this means that every time the user types a new char, if remote results are slower to arrive, we'd end up adding historical results and then they would be pushed down by search suggestions, and this causes continuous flicker while typing.
What the old urlbar does is replacing same-type results, and once a search is done it removes the "stale" results that don't apply anymore. This prevents flicker of results, because before removing search suggestions the view waits for new ones to arrive (and often they may be the same already there).

This is implemented in UnifiedComplete in the legacy implementation, but in the Quantum Bar we can't reuse that, because the new API inserts new results one by one and lets the sorting to the muxer. Though, the view can likely do something like this using the result type/source.

This flicker prevention is probably more important than any resource saved by reusing elements.

Points: --- → 5
Blocks: 1539804
Assignee: nobody → dao+bmo
Status: NEW → ASSIGNED
Blocks: 1530338
Duplicate of this bug: 1540766
Type: enhancement → defect
Iteration: --- → 68.3 - Apr 15 - 28
Depends on: 1545394
Attachment #9057291 - Attachment description: Bug 1535656 - WIP patch → Bug 1535656 - Quantum bar results flicker while typing a search.
Attached video screencast.mov

Hello Dão. I also noticed a flicker in the Drop Down. Not sure if it is the same issue as mentioned in this report or if I should create a new report. I am attaching a screencast. Thanks in advance.

No longer blocks: 1539804
Depends on: 1548817

While reviewing the patch I discovered a couple problems with the way the controller sends out notifications to the view, that I'm looking into in bug 1548817. That bug is necessary to properly fix flickering here.

Marco has identified a blocker for this (bug 1548817) and should have a simpler patch here once that's resolved.

Assignee: dao+bmo → mak77
Attachment #9057291 - Attachment is obsolete: true
Pushed by mak77@bonardo.net:
https://hg.mozilla.org/integration/autoland/rev/d6756af10859
Quantum bar results flicker while typing a search. r=dao
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68
Blocks: 1550480
QA Contact: cristian.comorasu

I reproduced this issue using Fx 67.0a1 (2019-03-15) on Windows 10 x64.
I can confirm this issue is fixed, I verified using Fx 68.0b6 and Fx 69.0a1 (2019-06-03), on macOS 10.13.6, Windows 10 x64 and Ubuntu 16.04 LTS.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.