Closed Bug 15358 Opened 20 years ago Closed 20 years ago

incorrect update after deselection of multiple selected text

Categories

(Core :: DOM: Selection, defect, P3)

defect

Tracking

()

VERIFIED FIXED

People

(Reporter: gemma, Assigned: mjudge)

References

()

Details

ctrl click to select several chunks of text from a paragraph or 2. then without
pressing ctrl key to deselect the text. The previously selected text should all
be deselected, but instead only a few of all the selected chunks are updated
correctly. The rest of the deselected text still being highlighted.
This occurs cross-platform on today's builds. It's probably either closely
related to --- or a duplicate of --- 13757.
OS: Windows NT → All
Hardware: PC → All
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → WORKSFORME
this seems fixed in the tip of the trunk now. i cant seem to reproduce any
problems. i am resolving this fixed but i will keep an eye on this.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
I can still reproduce this bug on Win32 (1999100708) slightly, unless I've
misunderstood the bug.

Judgester, if you'd like to see this firsthand, just drop by Eli-land any time.
Status: REOPENED → ASSIGNED
Target Milestone: M12
using the 10/12/99 build on win95 I am able to reproduce this:
1. open any file in the editor that has a fair amount of text in it.
2. press the [ctrl] key and select several segments of text
3. release the [ctrl] key
4. set focus anywhere within the text, the previously selected segments of text
remain highlighted.

Setting this one to M12, this should probably be fixed for beta
Target Milestone: M12 → M13
moving to M13, will work on it for beta
Status: ASSIGNED → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → FIXED
fixed fri. 1-7-00
Status: RESOLVED → VERIFIED
Verified fixed using 2000011208 Mac OS, 200001108 Win32 and 200001308 Linux
builds, using beppe's steps to reproduce.
You need to log in before you can comment on or make changes to this bug.