Closed Bug 15359 Opened 21 years ago Closed 21 years ago

View Source output lacks line breaks

Categories

(Core :: Layout, defect, P3)

defect

Tracking

()

VERIFIED DUPLICATE of bug 15649

People

(Reporter: elig, Assigned: buster)

Details

(Whiteboard: [TESTCASE] View Source must display line breaks)

Attachments

(1 file)

Starting with the 1999101008 builds, View Source output lacks line breaks in
between lines. (Checked Win32 & Linux).

[Full reproduction steps/etc omitted due to ease of reproducibility.]
QA Contact: petersen → elig
QA Assigning to self.
Assignee: rickg → kipp
Kipp -- this appears to be a content model bug.
If you look at nsViewSourceHTML.cpp::WillBuildModel(), you'll see that I'm
calling OpenBody(). If you dump the content model fter loading the document,
you'll see that the body element doesn't appear. Odd, no?

Here's my test case:

<html>
<body>
view
source
error
</body>
</html>
Status: NEW → ASSIGNED
Target Milestone: M17
Whiteboard: [TESTCASE] View Source must display line breaks
Attaching a strict HTML 4.0 test case & rewriting the bug report in
accordance to the guidelines, anyway.  Here goes:


Overview description:
 View Source output lacks all line breaks.

Steps to reproduce:
 1. View the attached test case
 2. Select "View / Page Source"

Actual results:
 - The source has neither spaces nor line breaks

Expected results:
 - Line breaks should be shown in the source, eg. each of the words "Here should
   be..." should be on a separate line.

Build date & platform:
 - Apparently all builds from 19991000108 on (tested 1999100409 Apprunner
   on WinNT4 + SP5 and the bug's still there)
 - All platforms
Works alright on build 19991006 on Linux.
The testcase displays linebreaks.
Bug 15649 was marked fixed, and this probably can be too.
Status: ASSIGNED → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
Marking this as dup of bug 15649.

*** This bug has been marked as a duplicate of 15649 ***
Status: RESOLVED → VERIFIED
Verified that the other bug is a duplicate of this bug.
You need to log in before you can comment on or make changes to this bug.