Closed Bug 1535930 Opened 1 year ago Closed 1 year ago

Intermittent dom/cache/test/mochitest/test_cache_match_vary.html | application crashed [@ TimerThread::Run()]

Categories

(Core :: DOM: Core & HTML, defect, P3, critical)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1334383

People

(Reporter: intermittent-bug-filer, Unassigned)

References

Details

(Keywords: crash, intermittent-failure, regression)

Crash Data

#[markdown(off)]
Filed by: aciure [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=234399172&repo=mozilla-central

https://queue.taskcluster.net/v1/task/Ej8HqAvBQOmavm2shheLdA/runs/0/artifacts/public/logs/live_backing.log

[task 2019-03-17T10:45:05.001Z] 10:45:05 INFO - 27 INFO TEST-START | dom/cache/test/mochitest/test_cache_match_vary.html
[task 2019-03-17T10:45:47.373Z] 10:45:47 INFO - wait for org.mozilla.fennec_aurora complete; top activity=com.android.launcher
[task 2019-03-17T10:45:47.578Z] 10:45:47 INFO - remoteautomation.py | Application ran for: 0:09:00.015053
[task 2019-03-17T10:45:48.297Z] 10:45:48 INFO - mozcrash Copy/paste: /builds/worker/workspace/build/linux64-minidump_stackwalk /tmp/tmpwRro5r/1967e684-7f93-9f90-29f4-604b66925905.dmp /builds/worker/workspace/build/symbols
[task 2019-03-17T10:45:59.213Z] 10:45:59 INFO - mozcrash Saved minidump as /builds/worker/workspace/build/blobber_upload_dir/1967e684-7f93-9f90-29f4-604b66925905.dmp
[task 2019-03-17T10:45:59.213Z] 10:45:59 INFO - mozcrash Saved app info as /builds/worker/workspace/build/blobber_upload_dir/1967e684-7f93-9f90-29f4-604b66925905.extra
[task 2019-03-17T10:45:59.216Z] 10:45:59 WARNING - PROCESS-CRASH | dom/cache/test/mochitest/test_cache_match_vary.html | application crashed [@ TimerThread::Run()]
[task 2019-03-17T10:45:59.217Z] 10:45:59 INFO - Crash dump filename: /tmp/tmpwRro5r/1967e684-7f93-9f90-29f4-604b66925905.dmp
[task 2019-03-17T10:45:59.217Z] 10:45:59 INFO - Operating system: Android
[task 2019-03-17T10:45:59.217Z] 10:45:59 INFO - 0.0.0 Linux 2.6.29-gea477bb #1 Wed Sep 26 11:04:45 PDT 2012 armv7l
[task 2019-03-17T10:45:59.217Z] 10:45:59 INFO - CPU: arm
[task 2019-03-17T10:45:59.218Z] 10:45:59 INFO - ARMv7 ARM Cortex-A8 features: swp,half,thumb,fastmult,vfpv2,edsp,neon,vfpv3
[task 2019-03-17T10:45:59.218Z] 10:45:59 INFO - 1 CPU
[task 2019-03-17T10:45:59.218Z] 10:45:59 INFO - GPU: UNKNOWN
[task 2019-03-17T10:45:59.218Z] 10:45:59 INFO - Crash reason: SIGSEGV /SEGV_MAPERR
[task 2019-03-17T10:45:59.219Z] 10:45:59 INFO - Crash address: 0x0
[task 2019-03-17T10:45:59.219Z] 10:45:59 INFO - Process uptime: not available
[task 2019-03-17T10:45:59.219Z] 10:45:59 INFO - Thread 19 (crashed)
[task 2019-03-17T10:45:59.219Z] 10:45:59 INFO - 0 libxul.so!TimerThread::Run() [Assertions.h:8ee97c045359ecd958e1032b0d6617741f20cf00 : 38 + 0x4]
[task 2019-03-17T10:45:59.219Z] 10:45:59 INFO - r0 = 0x00000000 r1 = 0x57517c0a r2 = 0x5751786b r3 = 0x000001bc
[task 2019-03-17T10:45:59.220Z] 10:45:59 INFO - r4 = 0x000001bc r5 = 0x6617f8c8 r6 = 0x00000000 r7 = 0x6617f920
[task 2019-03-17T10:45:59.220Z] 10:45:59 INFO - r8 = 0x6617f8d0 r9 = 0x52c082e0 r10 = 0x52c08310 r12 = 0x00000003
[task 2019-03-17T10:45:59.221Z] 10:45:59 INFO - fp = 0x00000000 sp = 0x6617f8a0 lr = 0x53639fbd pc = 0x5363d1a2
[task 2019-03-17T10:45:59.221Z] 10:45:59 INFO - Found by: given as instruction pointer in context
[task 2019-03-17T10:45:59.221Z] 10:45:59 INFO - 1 libxul.so!nsThread::ProcessNextEvent(bool, bool*) [nsThread.cpp:8ee97c045359ecd958e1032b0d6617741f20cf00 : 1179 + 0x5]
[task 2019-03-17T10:45:59.222Z] 10:45:59 INFO - r4 = 0x52cf8db0 r5 = 0x00000000 r6 = 0x00000001 r7 = 0x6617fde8
[task 2019-03-17T10:45:59.223Z] 10:45:59 INFO - r8 = 0xffffffff r9 = 0x6617f9d0 r10 = 0x6617fdf3 fp = 0x52cf8d30
[task 2019-03-17T10:45:59.224Z] 10:45:59 INFO - sp = 0x6617f928 lr = 0x5364126f pc = 0x5364126f
[task 2019-03-17T10:45:59.224Z] 10:45:59 INFO - Found by: call frame info
[task 2019-03-17T10:45:59.224Z] 10:45:59 INFO - 2 libxul.so!NS_ProcessNextEvent(nsIThread*, bool) [nsThreadUtils.cpp:8ee97c045359ecd958e1032b0d6617741f20cf00 : 482 + 0xd]
[task 2019-03-17T10:45:59.224Z] 10:45:59 INFO - r4 = 0x00000000 r5 = 0x52cf8d30 r6 = 0x400721f4 r7 = 0x6617fe08
[task 2019-03-17T10:45:59.224Z] 10:45:59 INFO - r8 = 0x52cc214c r9 = 0x52cf8d30 r10 = 0x52cc2140 fp = 0x400721f4
[task 2019-03-17T10:45:59.225Z] 10:45:59 INFO - sp = 0x6617fdf0 lr = 0x53643039 pc = 0x53643039
[task 2019-03-17T10:45:59.225Z] 10:45:59 INFO - Found by: call frame info
[task 2019-03-17T10:45:59.225Z] 10:45:59 INFO - 3 libxul.so!mozilla::ipc::MessagePumpForNonMainThreads::Run(base::MessagePump::Delegate*) [MessagePump.cpp:8ee97c045359ecd958e1032b0d6617741f20cf00 : 303 + 0x7]
[task 2019-03-17T10:45:59.225Z] 10:45:59 INFO - r4 = 0x52cc2130 r5 = 0x52cc11c0 r6 = 0x6617fe14 r7 = 0x6617fe38
[task 2019-03-17T10:45:59.225Z] 10:45:59 INFO - r8 = 0x52cc214c r9 = 0x52cf8d30 r10 = 0x52cc2140 fp = 0x400721f4
[task 2019-03-17T10:45:59.225Z] 10:45:59 INFO - sp = 0x6617fe10 lr = 0x53a07c3b pc = 0x53a07c3b
[task 2019-03-17T10:45:59.226Z] 10:45:59 INFO - Found by: call frame info

Andrei, as per bug 1535495 comment 1, please don't file these bugs in DOM: Animation.

Flags: needinfo?(aciure)
Component: DOM: Animation → DOM: Core & HTML
Flags: needinfo?(aciure)

Moving these bugs (intermittent test failures with crashes) out of P5.

Priority: P5 → --
Priority: -- → P3
See Also: → 1535495, 1531624
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1334383
You need to log in before you can comment on or make changes to this bug.