Closed Bug 1535962 Opened 8 months ago Closed 8 months ago

Send fewer Telemetry Events from Uptake Telemetry

Categories

(Firefox :: Remote Settings Client, defect)

67 Branch
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 68
Tracking Status
firefox67 --- fixed
firefox68 --- fixed

People

(Reporter: glasserc, Assigned: glasserc)

References

Details

Attachments

(1 file)

Per bug 1527442, sending a Telemetry Event for every Normandy non-match is prohibitively expensive. However, as of bug 1517469, we're now sending a Telemetry Event for every report of Uptake Telemetry. :sunahsuh has done some analysis and concluded that with this change, we can expect an increase of 75% of telemetry pings, leading to an increased cost of tens of thousands of dollars per month. To avoid this, we want to reduce the number of events sent. :sunahsuh recommends sending all events except on the release channel, and on the release channel, send events for a 1% sample of clients (using an algorithm like crc_32(client_id)%100. We believe this will provide most of the real-time data we need to spot problems with remote settings/normandy uptake, but without the cost of having to store and process such a volume of data.

Duplicate of this bug: 1534663
Assignee: nobody → eglassercamp
Pushed by eglassercamp@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/422b32187e46
Introduce a sample rate for reporting uptake telemetry events r=leplatrem

Comment on attachment 9051589 [details]
Bug 1535962: Introduce a sample rate for reporting uptake telemetry events

Beta/Release Uplift Approval Request

  • Feature/Bug causing the regression: Bug 1517469
  • User impact if declined: Mozilla will have to spend tens of thousands of dollars a month to handle telemetry pings sent by users on Release channel.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Accepting this change could cause Firefox to stop reporting Uptake Telemetry events for both Remote Settings and Normandy. However, because this is a new feature, this worst case just means that we have to wait another release cycle to get this operational data.
  • String changes made/needed:
Attachment #9051589 - Flags: approval-mozilla-beta?
Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68

Comment on attachment 9051589 [details]
Bug 1535962: Introduce a sample rate for reporting uptake telemetry events

Telemetry patch to reduce costs on the release channel for new real time telemetry events, looks reasonable and safe, uplift accepted for 67 beta 4, thanks!

Attachment #9051589 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.