mach build failing in artifact mode

RESOLVED FIXED in Firefox 68

Status

enhancement
RESOLVED FIXED
5 months ago
5 months ago

People

(Reporter: daksh17336, Assigned: arai)

Tracking

unspecified
mozilla68
Unspecified
All

Firefox Tracking Flags

(firefox68 fixed)

Details

Attachments

(1 attachment)

./mach build gives the following error

~/mozilla-central ./mach build
 0:01.14 Clobber not needed.
 0:01.15 Adding make options from /Users/daksh/mozilla-central/mozconfig
    MOZ_OBJDIR=/Users/daksh/mozilla-central/objdir-frontend-debug-artifact
    OBJDIR=/Users/daksh/mozilla-central/objdir-frontend-debug-artifact
    FOUND_MOZCONFIG=/Users/daksh/mozilla-central/mozconfig
    export FOUND_MOZCONFIG
 0:01.17 /usr/bin/make -f client.mk -s
 0:05.22 hg suggested 0 candidate revisions
 0:05.22 Error running mach:
 0:05.22     ['--log-no-times', 'artifact', 'install']
 0:05.22 The error occurred in code that was called by the mach command. This is either
 0:05.22 a bug in the called code itself or in the way that mach is calling it.
 0:05.23 You should consider filing a bug for this issue.
 0:05.23 If filing a bug, please include the full output of mach, including this error
 0:05.23 message.
 0:05.23 The details of the failure are as follows:
 0:05.23 IndexError: list index out of range
 0:05.23   File "/Users/daksh/mozilla-central/python/mozbuild/mozbuild/mach_commands.py", line 1280, in artifact_install
 0:05.23     return artifacts.install_from(source, distdir or self.distdir)
 0:05.23   File "/Users/daksh/mozilla-central/python/mozbuild/mozbuild/artifacts.py", line 1281, in install_from
 0:05.23     return self.install_from_recent(distdir)
 0:05.23   File "/Users/daksh/mozilla-central/python/mozbuild/mozbuild/artifacts.py", line 1202, in install_from_recent
 0:05.23     return self._install_from_hg_pushheads(hg_pushheads, distdir)
 0:05.23   File "/Users/daksh/mozilla-central/python/mozbuild/mozbuild/artifacts.py", line 1181, in _install_from_hg_pushheads
 0:05.23     for trees, hg_hash in hg_pushheads:
 0:05.23   File "/Users/daksh/mozilla-central/python/mozbuild/mozbuild/artifacts.py", line 1074, in _find_pushheads
 0:05.23     candidate_pushheads = self._pushheads_from_rev(last_revs[0].rstrip(),
 0:05.27 make[3]: *** [recurse_artifact] Error 1
 0:05.27 make[2]: *** [artifact] Error 2
 0:05.27 make[1]: *** [default] Error 2
 0:05.28 make: *** [build] Error 2
 0:05.28 0 compiler warnings present.

This error had happened because of unbundling and not doing a hg pull after it.

Adding the default's URL and doing hg pull followed by hg update fixes the bug for me. ./mach build works thereafter

Assignee: nobody → arai.unmht
Severity: blocker → normal
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
OS: macOS → All
Pushed by arai_a@mac.com:
https://hg.mozilla.org/integration/autoland/rev/6dea290b80da
Throw error with more information when there is no public revision while building artifact mode. r=chmanchester
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
You need to log in before you can comment on or make changes to this bug.