Closed Bug 1535995 Opened 7 months ago Closed 7 months ago

Check that group information is up to date

Categories

(Core :: DOM: Quota Manager, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla68
Tracking Status
firefox67 + fixed
firefox68 --- fixed

People

(Reporter: janv, Assigned: janv)

References

(Depends on 1 open bug)

Details

Attachments

(1 file)

This will fix bug 1516333 and bug 1422815.

Blocks: 1516333
Blocks: 1422815
Assignee: nobody → jvarga
Pushed by jvarga@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/93677154ad25
Check that group information is up to date; r=asuth
Pushed by jvarga@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/40b1d8d859e2
Quick followup patch to fix an ESlint failure; r=asuth
Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
Pushed by rgurzau@mozilla.com:
https://hg.mozilla.org/mozilla-central/rev/2abb636ad481
Quick followup patch to fix an ESlint failure; r=asuth

Does this need a Beta uplift request to fix the crash in bug 1516333?

Flags: needinfo?(jvarga)
Flags: in-testsuite+

(In reply to Ryan VanderMeulen [:RyanVM] from comment #7)

Does this need a Beta uplift request to fix the crash in bug 1516333?

Yes, there's still a chance that LSNG will be enabled in 67, so this bug needs to be fixed to avoid the crash.

Jan, please request a beta uplift then, thanks :)

Comment on attachment 9051609 [details]
Bug 1535995 - Check that group information is up to date; r=asuth

Beta/Release Uplift Approval Request

  • Feature/Bug causing the regression: None
  • User impact if declined: Users experience crashes especially in early beta with new local storage implementation enabled.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): I think it's low risk since the fix has been verified in Nightly, we are early in the beta cycle and code changes are quite small.
  • String changes made/needed: None
Flags: needinfo?(jvarga)
Attachment #9051609 - Flags: approval-mozilla-beta?

Comment on attachment 9051609 [details]
Bug 1535995 - Check that group information is up to date; r=asuth

Fix for crashes in (bug 1516333, bug 1422815) with tests. No crashes on Nightly for bug 1516333 since it landed a week ago, uplift approved for 67 beta 5, thanks.

Attachment #9051609 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Depends on: 1536596
Regressions: 1555869
You need to log in before you can comment on or make changes to this bug.