Closed Bug 1536007 Opened 2 years ago Closed 1 year ago

Add custom upwards backfilling

Categories

(Tree Management :: Treeherder: Job Triggering & Cancellation, enhancement, P2)

enhancement

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: igoldan, Assigned: aryx)

References

Details

Attachments

(1 file)

ATM we have a custom backfilling feature, which allows us to backfill & retrigger up to 10 missing jobs. Execution here runs chronologically, from most recent jobs to older ones.

This feature works thanks to only 3 parameters:

depth: 5
inclusive: false
times: 1

While investigating perf regressions, I had cases when I was missing more than 10 jobs. For the missing jobs which this tool couldn't easily backfill, I had to manually backfill each missing job, then come again to do the retriggers.

This could be easily fixed in 2 ways.
Either by extending the depth parameter to 20 or even 25.
Or keep the same depth, but add another direction parameter, which can have downwards or upwards values. After doing the usual 10 retriggers, I could go to the available alert from the bottom, and do another backfill upwards.

Personally, I'd opt for increasing the threshold.

Joel, what do you think?

Flags: needinfo?(jmaher)

This sounds similar to: bug 1515060

Flags: needinfo?(jmaher)

Joel, are you okay with the max depth getting increased to backfill up to 25 pushes? As a custom action, this can only be done for one unique job type at once.

Flags: needinfo?(jmaher)

25 pushes is fine.

Flags: needinfo?(jmaher)
Assignee: nobody → aryx.bugmail
Duplicate of this bug: 1515060
Pushed by archaeopteryx@coole-files.de:
https://hg.mozilla.org/integration/autoland/rev/46193fc0be25
Change maximum depth of backfills from 10 to 25. r=dustin
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.