Open Bug 1536018 Opened 7 months ago Updated 18 days ago

Alert summary's status doesn't properly update

Categories

(Tree Management :: Perfherder, defect, P3)

defect

Tracking

(Not tracked)

REOPENED

People

(Reporter: igoldan, Unassigned)

References

(Regression)

Details

(Keywords: regression, Whiteboard: [lang=py])

Steps to reproduce:

  1. Go to https://treeherder.mozilla.org/perf.html#/alerts?id=19785
  2. Make sure alerts are in untriaged state. Reset them if not.
  3. Mark them as confirming.
  4. Then mark them as acknowledged.

Expected:
Alert summary is in improvement state.
What we actually get:
Alert summary remains in confirming state.

Assignee: igoldan → nobody
Keywords: good-first-bug
Whiteboard: [lang=py]
Depends on: 1523710

This will get fixed during the conversion.

Assignee: nobody → sclements
No longer depends on: 1523710
Priority: P2 → P1
Depends on: 1523710
Status: NEW → ASSIGNED

I think this might be a backend logic issue rather than a UI issue. After following the steps you listed, the alertSummary status goes from "untriaged" to "confirming" and then to "investigating".

Is this still a problem Ionut?

Flags: needinfo?(igoldan)

(In reply to Sarah Clements [:sclements] - PTO Aug 19 - Sept 3 from comment #3)

Is this still a problem Ionut?

You are right about this. Those precise STR no longer reproduce.
But there's still a problem. Please follow this new STR.

Steps to reproduce:

  1. Go to https://treeherder.mozilla.org/perf.html#/alerts?id=19785
  2. Make sure alerts are in untriaged state. Reset them if not.
  3. Mark them as confirming.

Expected:
Alert summary is in confirming state.
What we actually get:
Alert summary remains in untriaged state.

Flags: needinfo?(igoldan)

Ionut, it seems these changes to the "confirming" status will affect this bug. Should this be closed?

Flags: needinfo?(igoldan)

(In reply to Sarah Clements [:sclements] from comment #5)

Ionut, it seems these changes to the "confirming" status will affect this bug. Should this be closed?

You are right. The plan for the PR you posted should fix this problem.

Flags: needinfo?(igoldan)
Regressed by: 1451657
Status: ASSIGNED → RESOLVED
Closed: 23 days ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1582108
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Assignee: sclements → nobody
Priority: P1 → P3
You need to log in before you can comment on or make changes to this bug.