Closed Bug 1536253 Opened 7 months ago Closed 7 months ago

browser_dbg-sourcemapped-scopes.js runs for 20 minutes on linux64/debug

Categories

(DevTools :: Debugger, enhancement, P5)

enhancement

Tracking

(firefox68 fixed)

RESOLVED FIXED
Firefox 68
Tracking Status
firefox68 --- fixed

People

(Reporter: gbrown, Assigned: gbrown)

Details

Attachments

(1 file)

In continuous integration, the devtools/client/debugger/new/test/mochitest/browser_dbg-sourcemapped-scopes.js test runs for a long, long time on linux64/debug -- about 20 minutes for this one test.

https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=234517337&repo=mozilla-central&lineNumber=20571

[task 2019-03-18T12:49:09.530Z] 12:49:09 INFO - TEST-OK | devtools/client/debugger/new/test/mochitest/browser_dbg-sourcemapped-scopes.js | took 1194967ms

It looks like the run time is well-known:

https://searchfox.org/mozilla-central/rev/7abb9117c8500ed20833746c9f8e800fce3a4688/devtools/client/debugger/new/test/mochitest/browser_dbg-sourcemapped-scopes.js#4

// This test can be really slow on debug platforms and should be split.
requestLongerTimeout(30);

The problem is that when a test runs for this long, it makes it very difficult for the test harness to balance load across chunks. Currently some linux64/debug devtools test chunks run in just 10 minutes and others take over 60 minutes.

Can the test be split, or optimized, etc such that it runs in < 5 minutes? 10?? Otherwise, would it be okay to disable the test on debug only?

Flags: needinfo?(jlaster)
Priority: -- → P2

I think it is okay to disable it on debug platforms.

Flags: needinfo?(jlaster)
Priority: P2 → P5

Skip test on debug, where this long test runs very slow (over 20 minutes).

Pushed by gbrown@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8b08bbc890d4
Skip browser_dbg-sourcemapped-scopes.js on debug; r=jmaher
Assignee: nobody → gbrown
Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68
You need to log in before you can comment on or make changes to this bug.