Closed Bug 1536309 Opened 2 years ago Closed 2 years ago

Make it possible to optionally enable frame dumps in layout-debugger in non-DEBUG builds

Categories

(Core :: Layout, enhancement, P5)

enhancement

Tracking

()

RESOLVED FIXED
mozilla68
Tracking Status
firefox68 --- fixed

People

(Reporter: mats, Assigned: mats)

Details

Attachments

(1 file)

No description provided.

Adding these lines to .mozconfig:

mk_add_options "export CXXFLAGS=-DDEBUG_FRAME_DUMP"
ac_add_options --enable-layout-debugger

makes the "Dump -> Frames" menu item work in Opt builds.

Maybe --enable-layout-debugger should be enough to allow frame dumping? If --enable-layout-debugger is set, then we know we're in a non-standard configuration that we're not going to ship to users, so it shouldn't be harmful to just make frame dumping work without needing the CXXFLAGS.

Yeah, that's probably more convenient.

It would be easy to add || defined(MOZ_LAYOUT_DEBUGGER)
to the definition in nsFrameList.h, but the problem is
that MOZ_LAYOUT_DEBUGGER is just a build flag that isn't
propagated to the compiler. So, I think this patch is
good enough for now, since I don't want to deal with
build config stuff.

Pushed by mpalmgren@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/732a78e6fc4f
Make it possible to optionally enable frame dumps in layout-debugger in non-DEBUG builds. r=dholbert
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
You need to log in before you can comment on or make changes to this bug.