displaying image generated by a php script will lead to two downloads of the image

RESOLVED WORKSFORME

Status

()

Core
ImageLib
RESOLVED WORKSFORME
16 years ago
15 years ago

People

(Reporter: SR, Assigned: Stuart Parmenter)

Tracking

({perf})

Trunk
x86
All
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.1a) Gecko/20020611
BuildID:    2002061104

If you fetch the url with mozilla, you'll notice that the images
looks like an animated one. This is wrong.
I generate a random image with this script, and fetching it once
seems to lead to downloading it twice, hence the feeling of animation.


Reproducible: Always
Steps to Reproduce:
1.fetch the url
2.look at the arrows, they move once


Actual Results:  you see 2 arrows, then they move to a different place.

Expected Results:  you see 2 arrows, still.

Comment 1

16 years ago
WFM, 2002-06-22-08 (trunk) on Windows 98 SE.
Confirmed on Linux build 2002-06-18-08.  Compare bug 119132 and bug  92722
(though there is no POST here and there _should_ be no reframe..)
Assignee: Matti99 → pavlov
Component: Browser-General → ImageLib
Depends on: 92722
OS: Windows 98 → All
QA Contact: imajes-qa → tpreston
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

16 years ago
Keywords: perf

Comment 3

16 years ago
Sounds also a lot like Bug 121084 (The testcase URL there is a similar script)
(Reporter)

Comment 4

16 years ago
Concerning the cache comments (of <a 
href="http://bugzilla.mozilla.org/show_bug.cgi?id=121084">Bug 121084</a>, I've 
done a few things to try to avoid the bug :
1- I Added "Cache-Control: no-cache" in the headers of my HTTP response;
2a- I cleaned both memory and disk caches, and restarted Mozilla
2b- I also tried without a restart of Mozilla

the image is still loaded twice.

Updated

16 years ago
Depends on: 98890
(Reporter)

Comment 5

16 years ago
bug still is present in build ID 2002072104
(Reporter)

Comment 6

16 years ago
Bug still there with ID 2002091014.
My current configuration is windows XP :
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2a) Gecko/20020910
(Reporter)

Comment 7

16 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2b) Gecko/20021016
Hey this *looks* fixed !

Comment 8

16 years ago
Yeah, I can not seem to reproduce this anymore with BuildID 2002101719 on Red
Hat Linux 8.0
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021130

The image does not change except when you reload the page.
Bug seems to be fixed.

Comment 10

15 years ago
To me it seems to be WFM too.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.