Closed Bug 1536574 Opened 2 years ago Closed 2 years ago

Font rendering in Nightly 68

Categories

(Core :: CSS Parsing and Computation, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1536718

People

(Reporter: koutris, Unassigned)

Details

(Keywords: regression)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

Steps to reproduce:

Nothing in particular. Just did my daily nightly upgrade.

Actual results:

The fonts in various sites changed from Arial to something else. Verdana or Tahoma. The rendering is now similar to Google Chrome. Sites affected are www.adslgr.com, arstechnica.com, gmail.com. I use the same settings from Netscape era and I never change them.

Expected results:

Firefox should respect my font settings to Arial 14. Instead it has changed to something else.

Component: Untriaged → CSS Parsing and Computation
Product: Firefox → Core

Can you go to about:config, search for font, and copy all the pref values that are there? In particular, is browser.display.use_document_fonts set to something different than 1?

Flags: needinfo?(koutris)

Tagging as a regression for now, but I think this is going to be bug 1536718.

Keywords: regression

browser.display.use_document_fonts 0

browser.display.auto_quality_min_font_size 20
browser.display.use_document_fonts 0
devtools.scratchpad.editorFontSize 12
font.blacklist.underline_offset FangSong,Gulim,GulimChe,MingLiU,MingLiU-ExtB,MingLiU_HKSCS,MingLiU-HKSCS-ExtB,MS Gothic,MS Mincho,MS PGothic,MS PMincho,MS UI Gothic,PMingLiU,PMingLiU-ExtB,SimHei,SimSun,SimSun-ExtB,Hei,Kai,Apple LiGothic,Apple LiSung,Osaka
font.default.ar sans-serif
font.default.el serif
font.default.he sans-serif
font.default.ja sans-serif
font.default.ko sans-serif
font.default.th sans-serif
font.default.x-armn serif
font.default.x-beng serif
font.default.x-cans serif
font.default.x-cyrillic serif
font.default.x-devanagari sans-serif
font.default.x-ethi serif
font.default.x-geor serif
font.default.x-gujr serif
font.default.x-guru serif
font.default.x-khmr serif
font.default.x-knda serif
font.default.x-math serif
font.default.x-mlym serif
font.default.x-orya serif
font.default.x-sinh serif
font.default.x-tamil serif
font.default.x-telu serif
font.default.x-tibt serif
font.default.x-unicode serif
font.default.x-western serif
font.default.zh-CN sans-serif
font.default.zh-HK sans-serif
font.default.zh-TW sans-serif
font.internaluseonly.changed false
font.language.group x-unicode
font.minimum-size.ar 0
font.minimum-size.el 14
font.minimum-size.he 0
font.minimum-size.ja 0
font.minimum-size.ko 0
font.minimum-size.th 10
font.minimum-size.x-armn 0
font.minimum-size.x-beng 0
font.minimum-size.x-cans 0
font.minimum-size.x-cyrillic 0
font.minimum-size.x-devanagari 0
font.minimum-size.x-ethi 0
font.minimum-size.x-geor 0
font.minimum-size.x-gujr 0
font.minimum-size.x-guru 0
font.minimum-size.x-khmr 0
font.minimum-size.x-knda 0
font.minimum-size.x-math 0
font.minimum-size.x-mlym 0
font.minimum-size.x-orya 0
font.minimum-size.x-sinh 0
font.minimum-size.x-tamil 0
font.minimum-size.x-telu 0
font.minimum-size.x-tibt 0
font.minimum-size.x-unicode 14
font.minimum-size.x-western 14
font.minimum-size.zh-CN 0
font.minimum-size.zh-HK 0
font.minimum-size.zh-TW 0
font.name-list.cursive.ar Comic Sans MS
font.name-list.cursive.el Comic Sans MS
font.name-list.cursive.he Guttman Yad, Ktav, Arial
font.name-list.cursive.ko Gungsuh
font.name-list.cursive.th Tahoma
font.name-list.cursive.x-cyrillic Comic Sans MS
font.name-list.cursive.x-ethi Visual Geez Unicode Title
font.name-list.cursive.x-math Comic Sans MS
font.name-list.cursive.x-unicode Comic Sans MS
font.name-list.cursive.x-western Comic Sans MS
font.name-list.cursive.zh-CN KaiTi, KaiTi_GB2312
font.name-list.cursive.zh-HK DFKai-SB
font.name-list.cursive.zh-TW DFKai-SB
font.name-list.emoji Segoe UI Emoji, Twemoji Mozilla
font.name-list.monospace.ar Courier New
font.name-list.monospace.el Courier New
font.name-list.monospace.he Fixed Miriam Transparent, Miriam Fixed, Rod, Courier New
font.name-list.monospace.ja MS Gothic, MS Mincho, Meiryo, Yu Gothic, Yu Mincho, MS PGothic, MS PMincho
font.name-list.monospace.ko GulimChe
font.name-list.monospace.th Tahoma
font.name-list.monospace.x-armn Arial AMU
font.name-list.monospace.x-beng Mitra Mono, Likhan, Mukti Narrow
font.name-list.monospace.x-cans Aboriginal Sans, OskiDakelh, Pigiarniq, Uqammaq
font.name-list.monospace.x-cyrillic Courier New
font.name-list.monospace.x-devanagari Mangal, Nirmala UI
font.name-list.monospace.x-ethi Ethiopia Jiret
font.name-list.monospace.x-geor BPG Classic 99U
font.name-list.monospace.x-gujr Shruti
font.name-list.monospace.x-guru Raavi, Saab
font.name-list.monospace.x-khmr Khmer OS, Khmer OS System
font.name-list.monospace.x-knda Tunga, AksharUnicode
font.name-list.monospace.x-math Courier New
font.name-list.monospace.x-mlym Rachana_w01, AnjaliOldLipi, Kartika, ThoolikaUnicode
font.name-list.monospace.x-orya ori1Uni, Kalinga
font.name-list.monospace.x-sinh Iskoola Pota, AksharUnicode
font.name-list.monospace.x-tamil Latha
font.name-list.monospace.x-telu Gautami, Akshar Unicode
font.name-list.monospace.x-tibt Tibetan Machine Uni, Jomolhari, Microsoft Himalaya
font.name-list.monospace.x-unicode Courier New
font.name-list.monospace.x-western Courier New
font.name-list.monospace.zh-CN SimSun, MS Song, SimSun-ExtB
font.name-list.monospace.zh-HK MingLiU_HKSCS, Ming(for ISO10646), MingLiU, MingLiU_HKSCS-ExtB
font.name-list.monospace.zh-TW MingLiU, MingLiU-ExtB
font.name-list.sans-serif.ar Segoe UI, Tahoma, Arial
font.name-list.sans-serif.el Arial
font.name-list.sans-serif.he Arial
font.name-list.sans-serif.ja Meiryo, Yu Gothic, MS PGothic, MS Gothic, Yu Mincho, MS PMincho, MS Mincho
font.name-list.sans-serif.ko Malgun Gothic, Gulim
font.name-list.sans-serif.th Tahoma
font.name-list.sans-serif.x-armn Arial AMU
font.name-list.sans-serif.x-beng Vrinda, Akaash, Likhan, Ekushey Punarbhaba
font.name-list.sans-serif.x-cans Aboriginal Sans
font.name-list.sans-serif.x-cyrillic Arial
font.name-list.sans-serif.x-devanagari Nirmala UI, Mangal
font.name-list.sans-serif.x-ethi GF Zemen Unicode
font.name-list.sans-serif.x-geor BPG Classic 99U
font.name-list.sans-serif.x-gujr Shruti
font.name-list.sans-serif.x-guru
font.name-list.sans-serif.x-khmr Khmer OS
font.name-list.sans-serif.x-knda Tunga, AksharUnicode
font.name-list.sans-serif.x-math Arial
font.name-list.sans-serif.x-mlym Rachana_w01, AnjaliOldLipi, Kartika, ThoolikaUnicode
font.name-list.sans-serif.x-orya ori1Uni, Kalinga
font.name-list.sans-serif.x-sinh Iskoola Pota, AksharUnicode
font.name-list.sans-serif.x-telu Gautami, Akshar Unicode
font.name-list.sans-serif.x-tibt Tibetan Machine Uni, Jomolhari, Microsoft Himalaya
font.name-list.sans-serif.x-unicode Arial
font.name-list.sans-serif.x-western Arial
font.name-list.sans-serif.zh-CN Microsoft YaHei, SimHei
font.name-list.sans-serif.zh-HK Arial, MingLiU_HKSCS, Ming(for ISO10646), MingLiU, MingLiU_HKSCS-ExtB
font.name-list.sans-serif.zh-TW Arial, Microsoft JhengHei, PMingLiU, MingLiU, MingLiU-ExtB
font.name-list.serif.ar Times New Roman
font.name-list.serif.el Times New Roman
font.name-list.serif.he Narkisim, David
font.name-list.serif.ja Yu Mincho, MS PMincho, MS Mincho, Meiryo, Yu Gothic, MS PGothic, MS Gothic
font.name-list.serif.ko Batang, Gulim
font.name-list.serif.th Tahoma
font.name-list.serif.x-armn Sylfaen
font.name-list.serif.x-beng Vrinda, Akaash, Likhan, Ekushey Punarbhaba
font.name-list.serif.x-cans Aboriginal Serif, BJCree Uni
font.name-list.serif.x-cyrillic Times New Roman
font.name-list.serif.x-devanagari Kokila, Raghindi
font.name-list.serif.x-ethi Visual Geez Unicode, Visual Geez Unicode Agazian
font.name-list.serif.x-geor Sylfaen, BPG Paata Khutsuri U, TITUS Cyberbit Basic
font.name-list.serif.x-gujr Shruti
font.name-list.serif.x-guru Raavi, Saab
font.name-list.serif.x-khmr PhnomPenh OT,.Mondulkiri U GR 1.5, Khmer OS
font.name-list.serif.x-knda Tunga, AksharUnicode
font.name-list.serif.x-math Latin Modern Math, STIX Two Math, XITS Math, Cambria Math, Libertinus Math, DejaVu Math TeX Gyre, TeX Gyre Bonum Math, TeX Gyre Pagella Math, TeX Gyre Schola, TeX Gyre Termes Math, STIX Math, Asana Math, STIXGeneral, DejaVu Serif, DejaVu Sans, Times New Roman
font.name-list.serif.x-mlym Rachana_w01, AnjaliOldLipi, Kartika, ThoolikaUnicode
font.name-list.serif.x-orya ori1Uni, Kalinga
font.name-list.serif.x-sinh Iskoola Pota, AksharUnicode
font.name-list.serif.x-tamil Latha
font.name-list.serif.x-telu Gautami, Akshar Unicode
font.name-list.serif.x-tibt Tibetan Machine Uni, Jomolhari, Microsoft Himalaya
font.name-list.serif.x-unicode Times New Roman
font.name-list.serif.x-western Times New Roman
font.name-list.serif.zh-CN SimSun, MS Song, SimSun-ExtB
font.name-list.serif.zh-HK Times New Roman, MingLiu_HKSCS, Ming(for ISO10646), MingLiU, MingLiU_HKSCS-ExtB
font.name-list.serif.zh-TW Times New Roman, PMingLiu, MingLiU, MingLiU-ExtB
font.name.cursive.ar
font.name.cursive.el
font.name.cursive.he
font.name.cursive.ja
font.name.cursive.ko
font.name.cursive.th
font.name.cursive.x-armn
font.name.cursive.x-beng
font.name.cursive.x-cans
font.name.cursive.x-cyrillic
font.name.cursive.x-devanagari
font.name.cursive.x-ethi
font.name.cursive.x-geor
font.name.cursive.x-gujr
font.name.cursive.x-guru
font.name.cursive.x-khmr
font.name.cursive.x-knda
font.name.cursive.x-math
font.name.cursive.x-mlym
font.name.cursive.x-orya
font.name.cursive.x-sinh
font.name.cursive.x-tamil
font.name.cursive.x-telu
font.name.cursive.x-tibt
font.name.cursive.x-unicode
font.name.cursive.x-western
font.name.cursive.zh-CN
font.name.cursive.zh-HK
font.name.cursive.zh-TW
font.name.monospace.ar
font.name.monospace.el Lucida Sans Typewriter
font.name.monospace.he
font.name.monospace.ja
font.name.monospace.ko
font.name.monospace.th
font.name.monospace.x-armn
font.name.monospace.x-beng
font.name.monospace.x-cans
font.name.monospace.x-cyrillic
font.name.monospace.x-devanagari
font.name.monospace.x-ethi
font.name.monospace.x-geor
font.name.monospace.x-gujr
font.name.monospace.x-guru
font.name.monospace.x-khmr
font.name.monospace.x-knda
font.name.monospace.x-math
font.name.monospace.x-mlym
font.name.monospace.x-orya
font.name.monospace.x-sinh
font.name.monospace.x-tamil
font.name.monospace.x-telu
font.name.monospace.x-tibt
font.name.monospace.x-unicode Lucida Sans Typewriter
font.name.monospace.x-western Lucida Sans Typewriter
font.name.monospace.zh-CN
font.name.monospace.zh-HK
font.name.monospace.zh-TW
font.name.sans-serif.ar
font.name.sans-serif.el Arial
font.name.sans-serif.he
font.name.sans-serif.ja
font.name.sans-serif.ko
font.name.sans-serif.th
font.name.sans-serif.x-armn
font.name.sans-serif.x-beng
font.name.sans-serif.x-cans
font.name.sans-serif.x-cyrillic
font.name.sans-serif.x-devanagari
font.name.sans-serif.x-ethi
font.name.sans-serif.x-geor
font.name.sans-serif.x-gujr
font.name.sans-serif.x-guru
font.name.sans-serif.x-khmr
font.name.sans-serif.x-knda
font.name.sans-serif.x-math
font.name.sans-serif.x-mlym
font.name.sans-serif.x-orya
font.name.sans-serif.x-sinh
font.name.sans-serif.x-tamil
font.name.sans-serif.x-telu
font.name.sans-serif.x-tibt
font.name.sans-serif.x-unicode Arial
font.name.sans-serif.x-western Arial
font.name.sans-serif.zh-CN
font.name.sans-serif.zh-HK
font.name.sans-serif.zh-TW
font.name.serif.ar
font.name.serif.el Arial
font.name.serif.he
font.name.serif.ja
font.name.serif.ko
font.name.serif.th
font.name.serif.x-armn
font.name.serif.x-beng
font.name.serif.x-cans
font.name.serif.x-cyrillic
font.name.serif.x-devanagari
font.name.serif.x-ethi
font.name.serif.x-geor
font.name.serif.x-gujr
font.name.serif.x-guru
font.name.serif.x-khmr
font.name.serif.x-knda
font.name.serif.x-math
font.name.serif.x-mlym
font.name.serif.x-orya
font.name.serif.x-sinh
font.name.serif.x-tamil
font.name.serif.x-telu
font.name.serif.x-tibt
font.name.serif.x-unicode Arial
font.name.serif.x-western Arial
font.name.serif.zh-CN
font.name.serif.zh-HK
font.name.serif.zh-TW
font.size.fixed.ar 13
font.size.fixed.el 14
font.size.fixed.he 13
font.size.fixed.ja 16
font.size.fixed.ko 16
font.size.fixed.th 13
font.size.fixed.x-armn 13
font.size.fixed.x-beng 13
font.size.fixed.x-cans 13
font.size.fixed.x-cyrillic 13
font.size.fixed.x-devanagari 13
font.size.fixed.x-ethi 13
font.size.fixed.x-geor 13
font.size.fixed.x-gujr 13
font.size.fixed.x-guru 13
font.size.fixed.x-khmr 13
font.size.fixed.x-knda 13
font.size.fixed.x-math 13
font.size.fixed.x-mlym 13
font.size.fixed.x-orya 13
font.size.fixed.x-sinh 13
font.size.fixed.x-tamil 13
font.size.fixed.x-telu 13
font.size.fixed.x-tibt 13
font.size.fixed.x-unicode 14
font.size.fixed.x-western 14
font.size.fixed.zh-CN 16
font.size.fixed.zh-HK 16
font.size.fixed.zh-TW 16
font.size.inflation.disabledInMasterProcess false
font.size.inflation.emPerLine 0
font.size.inflation.forceEnabled false
font.size.inflation.lineThreshold 400
font.size.inflation.mappingIntercept 1
font.size.inflation.maxRatio 0
font.size.inflation.minTwips 0
font.size.systemFontScale 100
font.size.variable.ar 16
font.size.variable.el 14
font.size.variable.he 16
font.size.variable.ja 16
font.size.variable.ko 16
font.size.variable.th 16
font.size.variable.x-armn 16
font.size.variable.x-beng 16
font.size.variable.x-cans 16
font.size.variable.x-cyrillic 16
font.size.variable.x-devanagari 16
font.size.variable.x-ethi 16
font.size.variable.x-geor 16
font.size.variable.x-gujr 16
font.size.variable.x-guru 16
font.size.variable.x-khmr 16
font.size.variable.x-knda 16
font.size.variable.x-math 16
font.size.variable.x-mlym 16
font.size.variable.x-orya 16
font.size.variable.x-sinh 16
font.size.variable.x-tamil 16
font.size.variable.x-telu 16
font.size.variable.x-tibt 16
font.size.variable.x-unicode 14
font.size.variable.x-western 14
font.size.variable.zh-CN 16
font.size.variable.zh-HK 16
font.size.variable.zh-TW 16
gfx.downloadable_fonts.disable_cache false
gfx.downloadable_fonts.enabled true
gfx.downloadable_fonts.fallback_delay 3000
gfx.downloadable_fonts.fallback_delay_short 100
gfx.downloadable_fonts.keep_color_bitmaps false
gfx.downloadable_fonts.otl_validation true
gfx.downloadable_fonts.validate_variation_tables true
gfx.downloadable_fonts.woff2.enabled true
gfx.font_ahem_antialias_none false
gfx.font_loader.delay 120000
gfx.font_loader.interval 1000
gfx.font_rendering.cleartype_params.cleartype_level -1
gfx.font_rendering.cleartype_params.enhanced_contrast -1
gfx.font_rendering.cleartype_params.force_gdi_classic_for_families Arial,Consolas,Courier New,Microsoft Sans Serif,Segoe UI,Tahoma,Trebuchet MS,Verdana
gfx.font_rendering.cleartype_params.force_gdi_classic_max_size 15
gfx.font_rendering.cleartype_params.gamma -1
gfx.font_rendering.cleartype_params.pixel_structure -1
gfx.font_rendering.cleartype_params.rendering_mode -1
gfx.font_rendering.directwrite.use_gdi_table_loading true
gfx.font_rendering.fallback.always_use_cmaps false
gfx.font_rendering.graphite.enabled true
gfx.font_rendering.opentype_svg.enabled true
gfx.font_rendering.wordcache.charlimit 32
gfx.font_rendering.wordcache.maxentries 10000
gfx.missing_fonts.notify false
intl.imm.composition_font
intl.imm.composition_font.japanist_2003 MS PGothic
layout.css.font-display.enabled true
layout.css.font-loading-api.enabled true
layout.css.font-variations.enabled true
layout.css.osx-font-smoothing.enabled false
layout.css.prefixes.font-features true
pdfjs.disableFontFace false
print.font-variations-as-paths true
reader.font_size 5
reader.font_type sans-serif
font
BooleanNumberString

Flags: needinfo?(koutris)

Cool, bug 1536718 should fix this then.

Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1536718
You need to log in before you can comment on or make changes to this bug.