Closed Bug 1536595 Opened 10 months ago Closed 10 months ago

Select All does not visually highlight everything at first

Categories

(Core :: DOM: Selection, defect, P1, major)

67 Branch
x86_64
Windows 10
defect

Tracking

()

RESOLVED FIXED
mozilla68
Tracking Status
firefox-esr60 --- unaffected
firefox66 --- unaffected
firefox67 blocking fixed
firefox68 --- fixed

People

(Reporter: alvinhochun, Assigned: masayuki)

References

Details

(Keywords: regression)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0

Steps to reproduce:

  1. Open certain pages (https://github.com/servo/webrender for example, scroll down a bit to see the readme text).
  2. Press Ctrl+A or press "Select All" on right-click context menu.

Actual results:

Some of the texts are not visually highlighted, but they act like they're selected.

Hovering cursor over links will cause them to visually update and possibly some weird updates (e.g. hovering over the link https://hg.mozilla.org/mozilla-central twice causes some interesting changes).

Certain actions will fix the visual issue (e.g. causing the window to lose focus).

Expected results:

All texts on the page are selected and highlighted.

OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64

[Tracking Requested - why for this release]: selection highlight is broken.

Reproduuced without WebRender.

Regression window:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=f74e07af9897218f5af09cc0188e753e74ecb58d&tochange=d011dfe8368374923cb69a0ab510d6814cbf3ab1

Regressed by: Bug 1533293

Nakano san, Your bunch of patch seems to cause the regression. Can you please look into this?

Blocks: 1533293
Status: UNCONFIRMED → NEW
Has Regression Range: --- → yes
Has STR: --- → yes
Component: Untriaged → Selection
Ever confirmed: true
Flags: needinfo?(masayuki)
Keywords: regression
Product: Firefox → Core

Oh, thanks, I'll investigate this soon.

Assignee: nobody → masayuki
Status: NEW → ASSIGNED
Flags: needinfo?(masayuki)
Priority: -- → P1

I can confirm the regression range. This is happening on almost all the sites I tested. Unfortunately this is in Beta 3 as bug 1533293 landed right before the merge. We can't ship 67 with that regression and it is also a very broken behavior for our Nightly population. Masayuki, let's backout the patch on both central and beta and reland a working patch later.

Flags: needinfo?(masayuki)

Looks like it already got backed out:

https://hg.mozilla.org/mozilla-central/rev/25398e555020
Backed out 3 changesets (bug 1533293) for causing Bug 1536595 a=backout

https://hg.mozilla.org/releases/mozilla-beta/rev/bfc174c4deb8
Backed out 3 changesets (bug 1533293) for causing Bug 1536595 a=backout

I'll let you guys set the correct flags.

FIXED by backout of bug 1533293.

Status: ASSIGNED → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
Severity: normal → major

Fixed by the additional patch of bug 1533293.

Flags: needinfo?(masayuki)
You need to log in before you can comment on or make changes to this bug.