Closed Bug 1536630 Opened 2 years ago Closed 2 years ago

Bundled libopus fails to build on aarch64

Categories

(Core :: Audio/Video, defect)

ARM64
Unspecified
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1530659
Tracking Status
firefox68 --- fixed

People

(Reporter: jbeich, Unassigned)

Details

(Keywords: regression)

$ c++ --version
FreeBSD clang version 8.0.0 (branches/release_80 355677) (based on LLVM 8.0.0)
Target: aarch64-unknown-freebsd13.0
Thread model: posix
InstalledDir: /usr/bin

$ ./mach build
[...]
media/libopus/silk/arm/arm_silk_map.c:31:10: fatal error: 'main_FIX.h' file not found
#include "main_FIX.h"
^~~~~~~~~~~~
1 error generated.

http://thunderx1.nyi.freebsd.org/data/head-arm64-default/p495404_s345044/logs/errors/firefox-66.0_1,1.log

Doh, it was already reported but not as a blocker for some reason.

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1530659
No longer blocks: 1522016
You need to log in before you can comment on or make changes to this bug.