Closed Bug 1536895 Opened 6 months ago Closed 6 months ago

FxA avatar menu Send Tab to Device can share `about:*` pages

Categories

(Firefox :: Firefox Accounts, enhancement)

enhancement
Not set

Tracking

()

VERIFIED FIXED
Firefox 68
Tracking Status
firefox67 --- verified
firefox68 --- verified

People

(Reporter: vbudhram, Assigned: vbudhram)

References

Details

(Whiteboard: [FxA])

Attachments

(1 file)

This was noticed earlier today, users can share any page from the FxA avatar submenu Send Tab to Device.

These pages include about:* pages. Previously, send tab to device was only found in page specific context menus and the page action menu.

Should we allow this and/or what restrictions should be in place? Also, how should the menu look in this scenario (disabled?)

:adavis, :rfeeley what are your thoughts on this and ux design it should have?

Flags: needinfo?(rfeeley)
Flags: needinfo?(adavis)
Duplicate of this bug: 1537699

The action doesn't actually work, right? The duplicate says that the receiving end gets a blank tab.

Seems to me we should disable it under the same circumstances where we hide the page action menu.

Blocks: 1524665
Flags: needinfo?(vbudhram)

We should match the behaviour of the other menus (context menu, page action menu) and disable it (reduce opacity of label and >) or is easier, hide the row entirely.

Flags: needinfo?(rfeeley)

My slight preference is to disable it and reduce opacity.

Like Feeley said, if it's easier to hide it, you can just do that.

Flags: needinfo?(adavis)
Assignee: nobody → vbudhram
Flags: needinfo?(vbudhram)
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/57eb03b1dfca
Disable send tab on Fxa avatar menu for unsupported pages, r=gijs
Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68

I have managed to reproduce this issue on an affected Firefox 68.0a1 (20190320112939) build using Windows 10 x64 by following the STR:

  1. Launch Firefox
  2. Log in with Firefox account
  3. Access one of the about:* pages (e.g. about:addons)
  4. Go to Firefox Account

ER:

  • "Send tab to device" option is grayed out.

AR:

  • "Send tab to device" option is available.

This issue is verified fixed using Firefox 67.0b18 and Firefox 68.0a1 (20190508215144) on the following OSes: Windows 10 x64, Ubuntu 18.04 x64, Windows 7 x64, macOS 10.14.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.