Closed Bug 1537117 Opened 3 years ago Closed 3 years ago

Ctrl+up/down for switching search engines no longer works

Categories

(Firefox :: Search, defect, P1)

67 Branch
defect

Tracking

()

VERIFIED FIXED
Firefox 68
Tracking Status
firefox-esr60 --- unaffected
firefox66 --- unaffected
firefox67 --- verified
firefox68 --- verified

People

(Reporter: gyorokpeter, Assigned: mikedeboer)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0

Steps to reproduce:

Type anything into the search box, then press Ctrl+Up/Down to switch search engines

Actual results:

Nothing

Expected results:

The search engine should have changed.
I use this feature because the autocomplete only works for the default search engine, so if e.g. I want to see the autocomplete for Wikipedia as opposed to Google, this is the quickest way to change it.

Component: Untriaged → Search
Blocks: 1524593
Status: UNCONFIRMED → NEW
Has Regression Range: --- → yes
Has STR: --- → yes
Ever confirmed: true
Keywords: regression

hi mike, could you take a look here - this issue seems to have been introduced with the search related changes from bug 1524593. thank you

Flags: needinfo?(mdeboer)
Assignee: nobody → mdeboer
Status: NEW → ASSIGNED
Flags: needinfo?(mdeboer)
Priority: -- → P1
Duplicate of this bug: 1537773
QA Whiteboard: [iris]

I also updated the logic to properly cycle through the visible search engines list
and added a unit test that was missing, somehow. This feature doesn't work on
OSX, I'm not sure why.

Pushed by mdeboer@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7b0b131d1b7d
Update the search engine quick-switching functionality to work with an async SearchService API. r=florian
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68

Comment on attachment 9054437 [details]
Bug 1537117 - Update the search engine quick-switching functionality to work with an async SearchService API. r?florian!

Beta/Release Uplift Approval Request

  • Feature/Bug causing the regression: Bug 1524593
  • User impact if declined: Users will notice that using Ctrl+up/down in the searchbar to quickly switching between search engines no longer works.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): This feature hasn't been covered by automated tests before and this changeset fixes that so it's less likely to regress in the future. The amount of changes needed were minimal and quite obvious, really.
  • String changes made/needed: n/a
Attachment #9054437 - Flags: approval-mozilla-beta?
No longer blocks: 1524593
Regressed by: 1524593

Can we get that verified on Nightly before uplifting? Thanks.

Flags: qe-verify+
QA Whiteboard: [iris] → [iris][qa-triaged]

I've been following 1518335 which this bug report seems to be a dupe of.

Anyway, I can confirm the bug is fixed on Nightly 68.0a1 (2019-04-02) (64-bit)

Thanks Arvid for checking!
I can confirm also this issue is verified fixed on Fx 68.0a1 (2019-04-04) across platforms (Windows 10 x64, Ubunutu 18.04 x64 and macOS 10.13).

Comment on attachment 9054437 [details]
Bug 1537117 - Update the search engine quick-switching functionality to work with an async SearchService API. r?florian!

Fix for a P1 in our Search component, with tests, verified by QE in Nightly, uplift approved for 67 beta 9, thanks.

Attachment #9054437 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

This issue is also verified fixed with Fx 67.0b9 (20190408123043) on Windows 10 x64, macOS 10.13 and Ubuntu 18.04 x64.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
Duplicate of this bug: 1536534
Duplicate of this bug: 1518335
You need to log in before you can comment on or make changes to this bug.