Location field should have Mac OS X graphical appearance

VERIFIED WONTFIX

Status

Camino Graveyard
Toolbars & Menus
--
trivial
VERIFIED WONTFIX
16 years ago
16 years ago

People

(Reporter: Albert Kammerer, Assigned: saari (gone))

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
OK, trivial might not begin to describe this one, but it's a look and feel
thing. The location field should have the same 3D graphic effect as text blocks
do in web pages.
(Assignee)

Updated

16 years ago
Status: NEW → ASSIGNED

Comment 1

16 years ago
Eh? The location field should look like an OS X text widget, which it does. It's
text fields in content the look crappy, and need fixing.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 2

16 years ago
My guess is this is not the place to hold an argument, so I will only post this
one response. Text entry fields in OS X have a nice 3D look to them. The text
fields in the body of web pages have that look in Navigator and look great. The
location field had this at one point in time in an early build and then it
disappeared. Now the location field just has a flat gray border. I think it
should have the 3D look of every other Mac OS X text field.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
Simon: I think Albert likes the text fields to have the setBezeled:YES.
Currently, in the URL bar, it's NO.  Apparently it was YES in an older build.

If you wanted to change this, it's a single button click in Interface Builder.
I'd submit a patch, but they never seem to work for me with .nibs.
(Reporter)

Comment 4

16 years ago
It sounds like that is exactly what I would like to see.

Comment 5

16 years ago
In CHLocationBar.mm, uncommenting the NSDrawLightBezel and commenting out the 
other code in the drawRect: method looks way better to me. Wonder why it is commented 
out?

Comment 6

16 years ago
Created attachment 94521 [details]
What the toolbar looks like using NSDrawLightBezel()

I tried the fix as Max suggested. This actually doesn't work because the
following two lines cover up the bezel.
  [[NSColor colorWithCalibratedWhite: 0.90 alpha: 1.0] set];
  NSFrameRectWithWidth([self bounds], 2.0);

After commenting out those two lines, I saw that the result, and the best all I
can say is that it looks horrible. But,you can see for yourself.

Comment 7

16 years ago
-> WONTFIX

There's no real point to this. You can't fix it easily in IB because the
location bar uses a custom class (so you can't just turn on the bezel to get it
to look right), you can't fix it with code easily, and it just looks like
getting it to look like a standard NSTextField is more work than it's worth.

BTW, the reason it looked correct at first was because an actual NSTextField was
used in prior versions of Chimera, as opposed to the custom class (to get
autocomplete to work).
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → WONTFIX
vrfy --unless pink, brade, sfraser think otherwise...
Status: RESOLVED → VERIFIED

Comment 9

16 years ago
*** Bug 183287 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.