crash when deleting archaic fields

VERIFIED DUPLICATE of bug 153480

Status

SeaMonkey
Download & File Handling
VERIFIED DUPLICATE of bug 153480
16 years ago
14 years ago

People

(Reporter: Bohdan Linda, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020529
BuildID:    20020621

I have found, that 1.1aplha has the ability of Download Manager. It remebers the
downloads befor it was aviable. When i tried to delete field, mozilla crashed. I
have found the field which does the problem

Reproducible: Always
Steps to Reproduce:
1.Open DM
2.Delete any field
3.

Actual Results:  crash mozilla

Expected Results:  delete item

download.rdf:
------------------------------------

<?xml version="1.0"?>
<RDF:RDF xmlns:NC="http://home.netscape.com/NC-rdf#"
         xmlns:RDF="http://www.w3.org/1999/02/22-rdf-syntax-ns#">
  <RDF:Seq about="NC:DownloadsRoot">
    <RDF:li resource="file:///home/bohdan/LimeWireLinux.bin"/>
    <RDF:li resource="file:///home/bohdan/dc-source-snapshot.tar.gz"/>
    <RDF:li resource="file:///home/bohdan/LimeWireLinux.bin"/>
    <RDF:li resource="file:///home/bohdan/libxml2-2.4.22.tar.gz"/>
    <RDF:li resource="file:///home/bohdan/dc-source-snapshot.tar.gz"/>
    <RDF:li resource="file:///home/bohdan/libxml2-2.4.22.tar.gz"/>
  </RDF:Seq>
  <RDF:Description about="file:///home/bohdan/libxml2-2.4.22.tar.gz"
                   NC:Name="libxml2-2.4.22.tar.gz"
                   NC:ProgressMode="none"
                   NC:StatusText="Finished">
    <NC:Transferred>0KB of  0KB</NC:Transferred>
    <NC:Transferred>1996KB of 1996KB</NC:Transferred>
    <NC:URL resource="ftp://xmlsoft.org/libxml2-2.4.22.tar.gz"/>
    <NC:File resource="file:///home/bohdan/libxml2-2.4.22.tar.gz"/>
    <NC:DownloadState NC:parseType="Integer">1</NC:DownloadState>
    <NC:ProgressPercent NC:parseType="Integer">100</NC:ProgressPercent>
  </RDF:Description>
  <RDF:Description about="file:///home/bohdan/LimeWireLinux.bin"
                   NC:Name="LimeWireLinux.bin"
                   NC:ProgressMode="none"
                   NC:StatusText="Finished">
    <NC:Transferred>2775KB of 2775KB</NC:Transferred>
    <NC:Transferred>2788KB of 2788KB</NC:Transferred>
    <NC:URL resource="http://limewire.gnutelliums.com/LimeWireLinux.bin"/>
    <NC:URL resource="http://www3.limewire.com/download/LimeWireLinux.bin"/>
    <NC:File resource="file:///home/bohdan/LimeWireLinux.bin"/>
    <NC:DownloadState NC:parseType="Integer">1</NC:DownloadState>
    <NC:ProgressPercent NC:parseType="Integer">100</NC:ProgressPercent>
  </RDF:Description>
  <RDF:Description about="file:///home/bohdan/dc-source-snapshot.tar.gz"
                   NC:Name="dc-source-snapshot.tar.gz"
                   NC:ProgressMode="none"
                   NC:StatusText="Finished">
    <NC:Transferred>621KB of 621KB</NC:Transferred>
    <NC:Transferred>619KB of 619KB</NC:Transferred>
    <NC:URL resource="http://dc.ketelhot.de/files/dcgui/snapshot/dc-source-snaps
hot.tar.gz"/>
    <NC:File resource="file:///home/bohdan/dc-source-snapshot.tar.gz"/>
    <NC:DownloadState NC:parseType="Integer">1</NC:DownloadState>
    <NC:ProgressPercent NC:parseType="Integer">100</NC:ProgressPercent>
  </RDF:Description>
</RDF:RDF>

Comment 1

16 years ago
do you have a talkback ID for the crash?
(Reporter)

Comment 2

16 years ago
sorry, it goes down, without talkback possibility. With that rdf file, you
should be able to demosntrate the problem. Try to delete any of that three lines

Comment 3

16 years ago
I see exactly the same problem. Just delete some entry from the list and Mozilla
crashes. I don't have talkback here.

pi
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

16 years ago

*** This bug has been marked as a duplicate of 153480 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
marking verified as a duplicate.

if you decide to reopen this bug, please clarify why.

search string for bugspam removal: SalviaGuaranitica
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.