Closed Bug 1537640 Opened 7 months ago Closed 7 months ago

Firefox adds zeros to http://192. making it really obnoxious to get to internal addresses

Categories

(Firefox :: Address Bar, defect, P2)

66 Branch
defect

Tracking

()

VERIFIED FIXED
Firefox 68
Tracking Status
firefox-esr60 --- unaffected
firefox66 --- wontfix
firefox67 --- verified
firefox68 --- verified

People

(Reporter: quanah, Assigned: mak)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

Steps to reproduce:

My firefox upgraded to release 66 tonight. It immediately exhibited a new behavior that is really annoying. If I go to the URL bar and type:

http://192.
or
https://192.

Firefox will immediately substitute 0.0.0 after the "." into the URL bar.

So to get to internal addresses like 192.168.1.1 I have to manually delete these values.

This did not happen prior to Firefox 66.

Regression window:
fromchange=d11bb3bd81951e0e5a66bc9e3ae80ca22d2ad13f&tochange=f2f4a6eb1576cba580ee99971f5fc035cbaeeab1

Regressed by:
f2f4a6eb1576 Marco Bonardo — Bug 1514780 - Use the Quantum Bar tokenizer in UnifiedComplete. r=adw

Blocks: 1514780
Status: UNCONFIRMED → NEW
Has Regression Range: --- → yes
Has STR: --- → yes
Component: Untriaged → Address Bar
Ever confirmed: true
Keywords: regression

It looks like autofilling, that may actually be a fix rather than a bug.
is the "0.0.0" part selected? could you please attach a screenshot?

Flags: needinfo?(quanah)

Nevermind, I just reproduced it using "https://192.", it looks like the Quantum Bar is not affected, the legacy urlbar is though.
If we enable the QB in 68 it may not be worth fixing this, though adding a test may be useful.

Flags: needinfo?(quanah)
Priority: -- → P2

Standard8 noticed there's some weird behavior with the QB as well when typing "http://1"

Hello, yes, the "." at the end is necessary for triggering the issue. :)

I only ran into this so quickly as I was setting up a brand new router when firefox updated.

Assignee: nobody → mak77
Status: NEW → ASSIGNED

Trying to autofill as urls breaks our assumptions.

Pushed by mak77@bonardo.net:
https://hg.mozilla.org/integration/autoland/rev/3779a2682cc7
Properly autofill partial IPs in the address bar. r=adw
Status: ASSIGNED → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68

Comment on attachment 9052997 [details]
Bug 1537640 - Properly autofill partial IPs in the address bar. r=adw!

Beta/Release Uplift Approval Request

  • Feature/Bug causing the regression: Bug 1514780
  • User impact if declined: typing IPs in the urlbar may not work as expected
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: Comment 0 has most details
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): small footprint patch with a test
  • String changes made/needed: none
Attachment #9052997 - Flags: approval-mozilla-beta?
Flags: qe-verify?
Flags: qe-verify? → qe-verify+

This uplift looks safe as it is for a disabled feature ut given that there will be studies in 67 around Quantum bar I'd like to see this patch verified on Nightly before taking the uplift.

QA Whiteboard: [qa-triaged]

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:68.0) Gecko/20100101 Firefox/68.0
Build ID: 20190326002640

Verified as fixed on the latest Nightly build.

Duplicate of this bug: 1539156

Comment on attachment 9052997 [details]
Bug 1537640 - Properly autofill partial IPs in the address bar. r=adw!

Limited patch fixing a visible functional regression with Quantumbar, fix verified in Nightly, uplift approved for 67 beta 6, thanks.

Attachment #9052997 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Duplicate of this bug: 1539630
Duplicate of this bug: 1539573

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:67.0) Gecko/20100101 Firefox/67.0
Build ID: 20190328152334

Verified as fixed on the latest Beta build (67b6).

Status: RESOLVED → VERIFIED
QA Whiteboard: [qa-triaged]
Flags: qe-verify+
Duplicate of this bug: 1540250
Duplicate of this bug: 1542200
Duplicate of this bug: 1548680
Duplicate of this bug: 1549815
No longer blocks: 1514780
Regressed by: 1514780
Duplicate of this bug: 1549820
Regressions: 1583616
You need to log in before you can comment on or make changes to this bug.