TD displays 800 px too wide on first visit after browser open

RESOLVED WORKSFORME

Status

()

Core
Layout
RESOLVED WORKSFORME
16 years ago
16 years ago

People

(Reporter: Wechsler, Assigned: Marc Attinasi)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.1a+) Gecko/20020623
BuildID:    2002062304

At http://www.ukcycling.net/mozbug/ ,  the 'sidebar' TD displays far too wide
(975px instead of 176px, according to the DOM inspector) the first time the page
is viewed after loading.
Once the page has been formatted correctly once, it will display correctly
therefter if viewed through the history list, but will generally foul up again
if the page is reloaded.

Reproducible: Sometimes
Steps to Reproduce:
1. Close ALL mozilla windows including quickstart
2. Load http://www.ukcycling.net/mozbug/
  (You should now see the error)
3.  Press 'Back' then 'Forwards'
  (The page should now work correctly)
4. Hit 'Reload'
  (The page will now fubar again, probably)

Actual Results:  Page is displayed with essential data forced offscreen

Expected Results:  Sidebar should be just wide enough to hold the 'login' and
'search' boxes.

This appears to be a CSS-induced error, as loading the page without CSS (use
http://www.ukcycling.net/mozbug/?css=off to exclude CSS) does not cause the
error. It appears to be the Table Data element that is calculated incorrectly
rather than anything inside it, according to checks with the DOM inspector.

The appearance of the error appears somewhat random. The steps above will
generally reproduce it, but not 100% of the time. There may be a timing issue,
as the bug is not seen if the displayed file is saved as .html then loaded from
disk.

The bug is also seen in the Mozilla 1.0 release
(Reporter)

Comment 1

16 years ago
Created attachment 88876 [details]
Page formatted wrongly
(Reporter)

Comment 2

16 years ago
Created attachment 88877 [details]
Page formatted correctly

Comment 3

16 years ago
WFM in 2002062308 PC/Win98.
(Reporter)

Comment 4

16 years ago
Forgot to mention:
Page displays fine under Win98/IE5.5, Win98/Opera 6.03
Seen broken on 
Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.7) Gecko/20011221
on another PC
(Reporter)

Comment 5

16 years ago
WFM on
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020529 

The two machines that I know of that don't work are on modem links. This machine
is on a direct link (not sure what type externally, but it's 10Mb/s to the web
proxy machine).

Couple this with the fact that the page works when loaded locally from a saved
HTML file, and it looks like a timing issue.

Bill - what sort of connection are you on?

Comment 6

16 years ago
WFM in the 2002-09-09-05 under OS X 10.2.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.