Closed Bug 1537719 Opened 3 years ago Closed 11 months ago

Intermittent browser/base/content/test/general/browser_bug1015721.js | undefined - timed out after 50 tries. -

Categories

(Firefox :: General, defect, P5)

defect

Tracking

()

RESOLVED FIXED

People

(Reporter: intermittent-bug-filer, Assigned: bogdan_tara)

Details

(Keywords: intermittent-failure, regression, Whiteboard: [stockwell fixed])

Attachments

(2 files)

#[markdown(off)]
Filed by: rgurzau [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=235156534&repo=autoland

https://queue.taskcluster.net/v1/task/Rxrq3VJ-SY2Ry-2mwjli7A/runs/0/artifacts/public/logs/live_backing.log

09:40:38 INFO - TEST-START | browser/base/content/test/general/browser_bug1015721.js
09:40:44 INFO - TEST-INFO | started process screencapture
09:40:44 INFO - TEST-INFO | screencapture: exit 0
09:40:44 INFO - Buffered messages logged at 09:40:39
09:40:44 INFO - Wait tab event: load
09:40:44 INFO - Tab event received: load
09:40:44 INFO - Console message: [JavaScript Error: "The character encoding of the HTML document was not declared. The document will render with garbled text in some browser configurations if the document contains characters from outside the US-ASCII range. The character encoding of the page must be declared in the document or in the transfer protocol." {file: "http://example.org/browser/browser/base/content/test/general/zoom_test.html" line: 0}]
09:40:44 INFO - Wait tab event: load
09:40:44 INFO - Tab event received: load
09:40:44 INFO - Console message: [JavaScript Error: "The character encoding of the HTML document was not declared. The document will render with garbled text in some browser configurations if the document contains characters from outside the US-ASCII range. The character encoding of the page must be declared in the document or in the transfer protocol." {file: "http://example.org/browser/browser/base/content/test/general/zoom_test.html" line: 0}]
09:40:44 INFO - TEST-PASS | browser/base/content/test/general/browser_bug1015721.js | Tab 1 is selected -
09:40:44 INFO - TEST-PASS | browser/base/content/test/general/browser_bug1015721.js | Initial zoom of tab 1 should be 1 -
09:40:44 INFO - TEST-PASS | browser/base/content/test/general/browser_bug1015721.js | Initial zoom of tab 2 should be 1 -
09:40:44 INFO - Waiting for tab 1 to be zoomed
09:40:44 INFO - Buffered messages finished
09:40:44 INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/general/browser_bug1015721.js | undefined - timed out after 50 tries. -
09:40:44 INFO - Stack trace:
09:40:44 INFO - chrome://mochikit/content/browser-test.js:test_ok:1304
09:40:44 INFO - chrome://mochitests/content/browser/browser/base/content/test/general/head.js:failAndContinue/<:344
09:40:44 INFO - GECKO(1967) | MEMORY STAT | vsize 4493MB | residentFast 407MB | heapAllocated 101MB
09:40:44 INFO - TEST-OK | browser/base/content/test/general/browser_bug1015721.js | took 5731ms
09:40:44 INFO - Not taking screenshot here: see the one that was previously logged
09:40:44 INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/general/browser_bug1015721.js | Found an unexpected tab at the end of test run: http://example.org/browser/browser/base/content/test/general/zoom_test.html -
09:40:44 INFO - Not taking screenshot here: see the one that was previously logged
09:40:44 INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/general/browser_bug1015721.js | Found an unexpected tab at the end of test run: http://example.org/browser/browser/base/content/test/general/zoom_test.html -
09:40:44 INFO - checking window state

Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → INCOMPLETE

Recent failure log:
https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=281922868&repo=autoland&lineNumber=2054

[task 2019-12-19T14:58:00.113Z] 14:58:00 INFO - TEST-PASS | browser/base/content/test/general/browser_bug1015721.js | Initial zoom of tab 2 should be 1 -
[task 2019-12-19T14:58:00.113Z] 14:58:00 INFO - Waiting for tab 1 to be zoomed
[task 2019-12-19T14:58:00.113Z] 14:58:00 INFO - Buffered messages finished
[task 2019-12-19T14:58:00.115Z] 14:58:00 INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/general/browser_bug1015721.js | undefined - timed out after 50 tries. -
[task 2019-12-19T14:58:00.115Z] 14:58:00 INFO - Stack trace:
[task 2019-12-19T14:58:00.116Z] 14:58:00 INFO - chrome://mochikit/content/browser-test.js:test_ok:1292
[task 2019-12-19T14:58:00.116Z] 14:58:00 INFO - chrome://mochitests/content/browser/browser/base/content/test/general/head.js:failAndContinue/<:398
[task 2019-12-19T14:58:00.116Z] 14:58:00 INFO - GECKO(1727) | MEMORY STAT | vsize 20975273MB | residentFast 1129MB
[task 2019-12-19T14:58:00.117Z] 14:58:00 INFO - TEST-OK | browser/base/content/test/general/browser_bug1015721.js | took 6001ms
[task 2019-12-19T14:58:00.117Z] 14:58:00 INFO - Not taking screenshot here: see the one that was previously logged
[task 2019-12-19T14:58:00.117Z] 14:58:00 INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/general/browser_bug1015721.js | Found an unexpected tab at the end of test run: http://example.org/browser/browser/base/content/test/general/zoom_test.html -
[task 2019-12-19T14:58:00.118Z] 14:58:00 INFO - Not taking screenshot here: see the one that was previously logged
[task 2019-12-19T14:58:00.118Z] 14:58:00 INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/general/browser_bug1015721.js | Found an unexpected tab at the end of test run: http://example.org/browser/browser/base/content/test/general/zoom_test.html -
[task 2019-12-19T14:58:00.121Z] 14:58:00 INFO - checking window state

Status: RESOLVED → REOPENED
Resolution: INCOMPLETE → ---

There are 29 total failures in the last 7 days on

Recent failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=283306399&repo=autoland&lineNumber=1855

[task 2020-01-03T05:39:21.233Z] 05:39:21 INFO - TEST-START | browser/base/content/test/general/browser_bug1015721.js
[task 2020-01-03T05:39:27.187Z] 05:39:27 INFO - TEST-INFO | started process screentopng
[task 2020-01-03T05:39:27.737Z] 05:39:27 INFO - TEST-INFO | screentopng: exit 0
[task 2020-01-03T05:39:27.739Z] 05:39:27 INFO - Buffered messages logged at 05:39:21
[task 2020-01-03T05:39:27.740Z] 05:39:27 INFO - Wait tab event: load
[task 2020-01-03T05:39:27.741Z] 05:39:27 INFO - Tab event received: load
[task 2020-01-03T05:39:27.743Z] 05:39:27 INFO - Console message: [JavaScript Error: "The character encoding of the HTML document was not declared. The document will render with garbled text in some browser configurations if the document contains characters from outside the US-ASCII range. The character encoding of the page must be declared in the document or in the transfer protocol." {file: "http://example.org/browser/browser/base/content/test/general/zoom_test.html" line: 0}]
[task 2020-01-03T05:39:27.744Z] 05:39:27 INFO - Wait tab event: load
[task 2020-01-03T05:39:27.746Z] 05:39:27 INFO - Console message: [JavaScript Error: "The character encoding of the HTML document was not declared. The document will render with garbled text in some browser configurations if the document contains characters from outside the US-ASCII range. The character encoding of the page must be declared in the document or in the transfer protocol." {file: "http://example.org/browser/browser/base/content/test/general/zoom_test.html" line: 0}]
[task 2020-01-03T05:39:27.746Z] 05:39:27 INFO - Buffered messages logged at 05:39:22
[task 2020-01-03T05:39:27.747Z] 05:39:27 INFO - Tab event received: load
[task 2020-01-03T05:39:27.748Z] 05:39:27 INFO - TEST-PASS | browser/base/content/test/general/browser_bug1015721.js | Tab 1 is selected -
[task 2020-01-03T05:39:27.749Z] 05:39:27 INFO - TEST-PASS | browser/base/content/test/general/browser_bug1015721.js | Initial zoom of tab 1 should be 1 -
[task 2020-01-03T05:39:27.749Z] 05:39:27 INFO - TEST-PASS | browser/base/content/test/general/browser_bug1015721.js | Initial zoom of tab 2 should be 1 -
[task 2020-01-03T05:39:27.750Z] 05:39:27 INFO - Waiting for tab 1 to be zoomed
[task 2020-01-03T05:39:27.751Z] 05:39:27 INFO - Buffered messages finished
[task 2020-01-03T05:39:27.752Z] 05:39:27 INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/general/browser_bug1015721.js | undefined - timed out after 50 tries. -
[task 2020-01-03T05:39:27.753Z] 05:39:27 INFO - Stack trace:
[task 2020-01-03T05:39:27.753Z] 05:39:27 INFO - chrome://mochikit/content/browser-test.js:test_ok:1292
[task 2020-01-03T05:39:27.754Z] 05:39:27 INFO - chrome://mochitests/content/browser/browser/base/content/test/general/head.js:failAndContinue/<:398
[task 2020-01-03T05:39:27.755Z] 05:39:27 INFO - GECKO(1455) | MEMORY STAT | vsize 20975266MB | residentFast 1121MB
[task 2020-01-03T05:39:27.755Z] 05:39:27 INFO - TEST-OK | browser/base/content/test/general/browser_bug1015721.js | took 5966ms
[task 2020-01-03T05:39:27.756Z] 05:39:27 INFO - Not taking screenshot here: see the one that was previously logged
[task 2020-01-03T05:39:27.757Z] 05:39:27 INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/general/browser_bug1015721.js | Found an unexpected tab at the end of test run: http://example.org/browser/browser/base/content/test/general/zoom_test.html -
[task 2020-01-03T05:39:27.758Z] 05:39:27 INFO - Not taking screenshot here: see the one that was previously logged
[task 2020-01-03T05:39:27.759Z] 05:39:27 INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/general/browser_bug1015721.js | Found an unexpected tab at the end of test run: http://example.org/browser/browser/base/content/test/general/zoom_test.html -
[task 2020-01-03T05:39:27.759Z] 05:39:27 INFO - checking window state

Justin can you assign someone to take a look?

Flags: needinfo?(dolske)
Whiteboard: [stockwell needswork:owner]
Assignee: nobody → btara
Pushed by ccoroiu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5065ab4d9c1c
Disable browser/base/content/test/general/browser_bug1015721.js on linux r=egao
Keywords: leave-open
Whiteboard: [stockwell disable-recommended] → [stockwell disabled]
Flags: needinfo?(dolske) → needinfo?(mstange)
Flags: needinfo?(mstange.moz) → needinfo?(gijskruitbosch+bugs)

This moves a bunch of tests over to a topical directory, and removes the
linux/windows running restrictions around browser_bug1015721.js
(now browser_mousewheel_zoom.js), given that it appears to run fine on try
and there are no recent logs with which we can diagnose failures.

It switches away from using FullZoom.reset repeatedly in the background_zoom
test because that trips https://bugzilla.mozilla.org/show_bug.cgi?id=1604236
which breaks subsequent tests.

Flags: needinfo?(gijskruitbosch+bugs)
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/f9cc517e7ca7
move page zoom tests and make them more reliable, r=morgan
Status: REOPENED → RESOLVED
Closed: 3 years ago11 months ago
Keywords: leave-open
Resolution: --- → FIXED
Whiteboard: [stockwell disabled] → [stockwell fixed]
You need to log in before you can comment on or make changes to this bug.